avr-libc-dev
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [avr-libc-dev] Nice to have: XCK Definition


From: Weddington, Eric
Subject: RE: [avr-libc-dev] Nice to have: XCK Definition
Date: Tue, 10 Mar 2009 21:36:37 -0600

 

> -----Original Message-----
> From: 
> address@hidden 
> [mailto:address@hidden
> org] On Behalf Of Frédéric Nadeau
> Sent: Tuesday, March 10, 2009 12:04 PM
> To: address@hidden
> Subject: Re: [avr-libc-dev] Nice to have: XCK Definition
> 
> I have run a first test on my program, result seems pretty good. It
> does not modify io files yet, it rather report suggested modification
> to stdout.
> 
> I have attached the program output.(Well it seems that there is a
> limit to attachment, please see:
> http://eclipse-serveur.dyndns.org/public/preliminary.txt ) If people
> interested in this
> feature could take a look at the output and gives comments, maybe even
> spot errors.
> 
> I know of one error is that CLKO(Clock Ouput) is sometime reported as
> CLK0. That is due to typo in XMLs file. I will patch that soon. If you
> append to find other thing like that, please let me know.
> 
> New defines will be added at the end of io files, just before the
> final #endif and will be printed as in the attached document. If you
> think of a better formatting, comments, spacing, etc, let me know.

So far it looks good.

A couple of minor suggestions:

- Generate a comment at the top of the section, something like:
/* Device Pin Definitions */
Be sure to use C89 comments, not the double slash.

- Put a blank line in between each grouping as it makes it easier to read, for 
example:
#define RXD0_DDR DDRE
#define RXD0_PORT PORTE
#define RXD0_PIN PINE
#define RXD0_IDX 0

#define PDI_DDR DDRE
#define PDI_PORT PORTE
#define PDI_PIN PINE
#define PDI_IDX 0

#define TXD0_DDR DDRE
#define TXD0_PORT PORTE
#define TXD0_PIN PINE
#define TXD0_IDX 1

...

If you *really* want a challenge, you could look into modifying the 
XML-to-header generation script "avrgcc-header":
<http://cvs.savannah.gnu.org/viewvc/avr-libc/xml/?root=avr-libc>
This would help with header files for future devices.

Eric Weddington




reply via email to

[Prev in Thread] Current Thread [Next in Thread]