[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Phpgroupware-users] Installation problem on RedHat 8

From: thorstuff
Subject: Re: [Phpgroupware-users] Installation problem on RedHat 8
Date: Wed, 20 Nov 2002 00:13:43 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0

I followed this procedure but it does not work with the existing data. I had the tarball for version 0.9.10 which the existing data is stored in. I installed it on the Red Hat 7 box, imported that data and checked to see that it would run. Everything did. Then I upgraded to 0.9.14. The setup program said the applications needed to be upgraded which I told it to do. When it got through it said that if there was no error message then the install was successful. When I click the Re-Check My Install button I get the message again that the applications need to be upgraded.
Also when I try to log in after successfully doing so before upgrading to 0.9.14 I get the following error message which I have received every other way I have attempted this upgrade:
Database error: Invalid SQL: select config_value from phpgw_config WHERE config_app='phpgwapi' and config_name='cache_phpgw_info'

File: /var/www/html/phpgroupware/phpgwapi/inc/
Line: 646Session halted.
Fatal error: Call to a member function on a non-object in /var/www/html/phpgroupware/phpgwapi/inc/ on line 565

The previous version will not run at all on the Red Hat 8/Apache 2.0 machine because of the login problem that was addressed earlier.

Any more suggestions would be appreciated.

Don Griffey
Thor Systems

Dave Hall wrote:
thorstuff <address@hidden> wrote:

Thanks for the reply Dave.


I had not thought of the part about the Administration app not 
there but you may be right. I did a parallel install of this app 
to my 
Red Hat 7 development box at home and  (both from the tarball). 
After I 
installed the apps the Red Hat 7 box had about three times as many 
database files as the Red Hat 8 box had. There had been four or 
attempts at installing the tarball before I tried it.

I have a lot of data in the previous install before the conversion 
Red Hat 7 to Red Hat 8 but I cannot  seemingly transfer it 
directly into 
the new install. To be honest I am not sure exactly what was done 
I was given the job. I did also follow the instructions about 
(if that is the right term) from the CVS.

Ok ... so you have drawn the short straw by the sounds of things.  I am
still a bit lost about what you are trying to acheive.  If you are
trying to move an install from one machine to another ... here is what I
would do:

mysqldump the old install

Untar the tarball ... run a cvs update

Copy over your old file.

Manually edit the header file for your new db server name

import the db data

Run the setup again to make sure everyting is upto date

That should be it.  If i have misunderstood, could you please explain a
bit more.

Sorry about the vagueness of the last part but I wasn't sure it 
was even 
relevant so I did not want to dwell on it. The host name under Red 
Hat 7 
was But that has to be replaced with localhost where it 
used. Mostly this in mysql database login scripts.

This now makes sense.

Hope this clears things up some.

Don Griffey

Dave Hall wrote:

doneg <address@hidden> wrote:


I am having a problem with an install of the phpgroupware 
on a 
RedHat 8 machine (Using Apache 2). I have updated the program 
CVS as noted in the "Can't log in" thread (I had that problem 
too.) but 
when the phpgroupware starts up I do not get the Administration 
icon to 
continue the administration process.

Ummm ... sounds like a bad setup.  I take that you do not have 
any real
data in your db.  

Go to setup - setup/config and check that you have the admin app
installed.  I would also suggest that you go to setup - 
setup/config -
create accounts - this should recreate the accounts properly.

btw what package system are you using? cvs, tarball, rpms?


While this may or may not have a bearing on the problem, I have 
had to 
go into all of my php app config files and change the host from 
machine url to "localhost." This has been something of an issue 
have worked for the past four days or so (off and on) to get the 
phpgroupware working. But whether it is a problem now I don't know.

Ummm ... i don't understand why you have done this.  But it could be
part of your problem.


Dave Hall (aka skwashd)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]