[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Phpgroupware-users] Installation problem on RedHat 8

From: Dave Hall
Subject: Re: [Phpgroupware-users] Installation problem on RedHat 8
Date: Sun, 17 Nov 2002 20:24:21 +1100

thorstuff <address@hidden> wrote:

> Thanks for the reply Dave.


> I had not thought of the part about the Administration app not 
> being 
> there but you may be right. I did a parallel install of this app 
> to my 
> Red Hat 7 development box at home and  (both from the tarball). 
> After I 
> installed the apps the Red Hat 7 box had about three times as many 
> database files as the Red Hat 8 box had. There had been four or 
> five 
> attempts at installing the tarball before I tried it.
> I have a lot of data in the previous install before the conversion 
> from 
> Red Hat 7 to Red Hat 8 but I cannot  seemingly transfer it 
> directly into 
> the new install. To be honest I am not sure exactly what was done 
> before 
> I was given the job. I did also follow the instructions about 
> updating 
> (if that is the right term) from the CVS.

Ok ... so you have drawn the short straw by the sounds of things.  I am
still a bit lost about what you are trying to acheive.  If you are
trying to move an install from one machine to another ... here is what I
would do:

mysqldump the old install

Untar the tarball ... run a cvs update

Copy over your old file.

Manually edit the header file for your new db server name

import the db data

Run the setup again to make sure everyting is upto date

That should be it.  If i have misunderstood, could you please explain a
bit more.

> Sorry about the vagueness of the last part but I wasn't sure it 
> was even 
> relevant so I did not want to dwell on it. The host name under Red 
> Hat 7 
> was But that has to be replaced with localhost where it 
> was 
> used. Mostly this in mysql database login scripts.

This now makes sense.

> Hope this clears things up some.
> Don Griffey
> Dave Hall wrote:
> >doneg <address@hidden> wrote:
> >
> >  
> >
> >>I am having a problem with an install of the phpgroupware 
> program 
> >>on a 
> >>RedHat 8 machine (Using Apache 2). I have updated the program 
> from 
> >>the 
> >>CVS as noted in the "Can't log in" thread (I had that problem 
> >>too.) but 
> >>when the phpgroupware starts up I do not get the Administration 
> >>icon to 
> >>continue the administration process.
> >>    
> >>
> >
> >Ummm ... sounds like a bad setup.  I take that you do not have 
> any real
> >data in your db.  
> >
> >Go to setup - setup/config and check that you have the admin app
> >installed.  I would also suggest that you go to setup - 
> setup/config -
> >create accounts - this should recreate the accounts properly.
> >
> >btw what package system are you using? cvs, tarball, rpms?
> >
> >  
> >
> >>While this may or may not have a bearing on the problem, I have 
> >>had to 
> >>go into all of my php app config files and change the host from 
> >>the 
> >>machine url to "localhost." This has been something of an issue 
> as 
> >>I 
> >>have worked for the past four days or so (off and on) to get the 
> >>phpgroupware working. But whether it is a problem now I don't know.
> >>    
> >>
> >
> >Ummm ... i don't understand why you have done this.  But it could be
> >part of your problem.
> >
> >Cheers
> >
> >Dave Hall (aka skwashd)
> >  
> >

Attachment: dave.hall.vcf
Description: Card for <>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]