[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Windows 2000 (more trouble)

From: Robert Weldon
Subject: RE: Windows 2000 (more trouble)
Date: Tue, 7 Nov 2000 08:33:02 -0500

Well, I did indeed get it working. Thanks for all the help... Windows
installation can be a real bear. I did a 3 month project some time back
involving creating an oracle data base with a Windows client - it took a
month to get the db done, and two months to work out all the bugs in
installing the ODBC drivers under Windows!

BTW, it seems that the path in putenv('TMPDIR',<temporary directory> needs
to be written as, for example, d:/usr/tmp, which is non-standard in both
UNIX and DOS. This  is what was giving me the trouble - I had assumed
"d:ŠÜusrŠÜtmp" or "//cygdrive/d/usr/tmp".

thanks again,


-----Original Message-----
From: Julian A. de Marchi, Ph.D [mailto:address@hidden
Sent: Monday, November 06, 2000 11:32 PM
To: Robert Weldon; address@hidden
Subject: RE: Windows 2000 (more trouble)

Indeed the pif is to TRY to set up sufficent environment space for the
subsequent batch file which calls bash (quite possibly unnecessarily)
in order to launch gzip and unzip all the fileset.  There are DOS versions
of gzip and I've put together an alternative installation using this, but
the stumbling block has been getting the installation paths piped into the
octaverc & start scripts.  I have to admit, Windows is a real pain to
into using only batch files.  The NullSoft installer is great for some
but we really need something more robust.  I've looked into the CygWin
installer (GNU GPL) but it's an imbroglio and I can't make head nor tail of
there are no instructions for putting it together; it's set up for CygWin
not really designed for general use as far as I can tell.  I'm on the fence
about purchasing a pro installer like VISE.  Any help would really be
appreciated.  In the meantime, perhaps installing under safe mode will help.

The GNUPlot broken pipe problem is quickly fixed by hand-editing the file
binŠÜstart and placing the correct path to wgnuplot.exe.  Sorry about ver. D.
It seems to be a toss-up... several folks have no trouble installing it,
while others on the same platform have.  I can't discover enough
information to be able to determine how this can be so.

with apologies,

-----Original Message-----
From: address@hidden
[mailto:address@hidden Behalf Of Robert Weldon
Sent: Monday, November 06, 2000 11:55 AM
To: address@hidden
Subject: RE: Windows 2000 (more trouble)

>> No guarantees -- a couple of bug reports have
>> slipped in -- but for most folks this seems to
>> work on all Windows versions:

Thank you. I installed this exe and had a bit of a problem... very similar
to the problem in the earlier email:

where, under Windows 98 the executable doesn't get installed. It seems that
the installer uses a "pif" file - I'm judging from a screen that flashes by
quite quickly.

Pif files are now obsolete, but under older versions of windows they set up
the memory usage for dos programs running in a Windows dos console. What I
see is a line saying something about the pif file, then several lines saying
"out of environment space." In Windows 2000, you can set environment space
by an environment variable:

comspec=<name of cmd.exe> /e:8192, which I've done, but the pif file may be
changing this?

So I downloaded the "c" version zip file and tried that...

Net result is that while typing pipe-gnuplot.exe at a dos prompt will now
actually launch gnuplot (progress!!), I still get a broken pipe warning!

Anyone else have these problems?


Robert Weldon
MathEngine Canada Inc.
465 McGill Street, First Floor
Montreal, Qc  H2Y 2H1 CANADA

Tel:  +1.(514)-287-1166
Fax:  +1.(514)-287-3360


-----Original Message-----
From: address@hidden
[mailto:address@hidden Behalf Of Robert Weldon
Sent: Sunday, November 05, 2000 7:07 PM
To: address@hidden
Subject: Windows 2000

I just spent two days installing, reinstalling, hacking, fighting, bullying
and pleading with cygwin, Octave and gnuplot.

Looks like something is wrong with the pipe. If I type something like, say,
gset, I get

error: stdin is not a tty!

warning: broken pipe

Does gnuplot-pipe.exe work under Windows 2000? Am I just wasting time? I
haven't been able to find the 2.0.16 version ( supposedly stable) as a
binary, so I've tried a couple packages featuring 2.0.30 and 2.0.31.

Can anyone help?



Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]