[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-libc-dev] SOLVED! atmega6490a support

From: Jeff Keyzer
Subject: Re: [avr-libc-dev] SOLVED! atmega6490a support
Date: Sat, 16 Apr 2011 12:56:12 -0500


Have you looked at CrossPack?


It ships with avr-gcc 4.3.3.

Jeff Keyzer

On Apr 16, 2011, at 12:19 PM, Chris Marrin wrote:

> What a world.
> I've solved the problem, in two different ways. 
> The thing that started all this rigamarole is the fact that macports, which 
> is a great way to get almost any tools that don't come with a Mac, only had 
> avr-gcc 4.0.2. That was not only pretty old, but didn't have support for the 
> latest chips. There is, in fact, an open bug in macports to get up to 4.3.2. 
> All the other important tools (avr-bintools, avr-libc and avrdude) are at 
> versions that are pretty close to current. So one way I solved the problem is 
> by installing avr-binutils from macports. But I was also able to get the 
> latest version from source to build, after applying the patches and adding 
> "--disable-werror" to configure. Apparently the Mac gcc compiler is pickier 
> than most.
> Looks like the basic problem was with binutils. After getting a good version, 
> the gcc configure started accurately reporting which chips it supported and 
> which it didn't.
> So all is well now. I'll post my scripts for how I did this soon.
> Thanks for the help!
> -----
> ~Chris
> address@hidden
> _______________________________________________
> AVR-libc-dev mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/avr-libc-dev

reply via email to

[Prev in Thread] Current Thread [Next in Thread]