[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-libc-dev] SOLVED! atmega6490a support

From: Chris Marrin
Subject: [avr-libc-dev] SOLVED! atmega6490a support
Date: Sat, 16 Apr 2011 10:19:25 -0700

What a world.

I've solved the problem, in two different ways. 

The thing that started all this rigamarole is the fact that macports, which is 
a great way to get almost any tools that don't come with a Mac, only had 
avr-gcc 4.0.2. That was not only pretty old, but didn't have support for the 
latest chips. There is, in fact, an open bug in macports to get up to 4.3.2. 
All the other important tools (avr-bintools, avr-libc and avrdude) are at 
versions that are pretty close to current. So one way I solved the problem is 
by installing avr-binutils from macports. But I was also able to get the latest 
version from source to build, after applying the patches and adding 
"--disable-werror" to configure. Apparently the Mac gcc compiler is pickier 
than most.

Looks like the basic problem was with binutils. After getting a good version, 
the gcc configure started accurately reporting which chips it supported and 
which it didn't.

So all is well now. I'll post my scripts for how I did this soon.

Thanks for the help!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]