[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-libc-dev] atmega6490a support

From: Chris Marrin
Subject: Re: [avr-libc-dev] atmega6490a support
Date: Sat, 16 Apr 2011 07:14:01 -0700

On Apr 16, 2011, at 4:40 AM, Ruud Vlaming wrote:

> On Saturday 16 April 2011, Chris Marrin wrote:
>> I'm trying to build the entire AVR toolchain for mac and am getting very 
>> frustrated. I've built gcc 4.5.2
> Interresting, if i try to build gcc 4.5.2 on the mac (10.6.7) i get:
>  configure: error: Cannot find GMP version 4.1.3 or higher.
>  GMP is the GNU Multi-Precision library:
> But i have added gmp 5.0.1 in the source directory of gcc, and even added
> LDFLAGS="-Wl,-search_paths_first" as configure option (although that
> should not be necessary). How where you able to build gcc 4.5.2 on
> your system?? (btw i think if you use 10.5.x it still works, but i cannot test
> that anymore)

I downloaded gmp 5.0.1, did a ./configure --prefix=/usr/local/ , then did a 
make and make install and that worked fine. I also installed mpfr 3.0.1 and mpc 
0.9 the same way. Do you need all 3? I'm not sure, but that got rid of that 

>> and then tried to build avr-libc 1.7.1. It failed because it could not find 
>> the 
>> tiny2313a device. I fixed that with a patch I got from here:  
> What binutils did you use? The cause may be there.

I installed binutils 2.21 using the instructions here:


I didn't install any patches from the MHV guys, but the only ones I have don't 
seem very relevant. The MHV tools are using 2.20.1, so I'll try that version 
and installing the patches next.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]