[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] trouble getting started...

From: David
Subject: Re: [Paparazzi-devel] trouble getting started...
Date: Tue, 21 Dec 2010 16:35:14 -0800

I use a MacBook. VMWare Fusion is excellent with USB. I concur VIrtualbox is 
not good with USB on OSX

Sent from my iPhone

On Dec 21, 2010, at 4:21 PM, Gareth Roberts <address@hidden> wrote:

> Hi James,
> Chris, I don't think there is an OSS version of Virtualbox for OSX, it's 
> amazing how much we take for granted in the linux world...
> I've got a Macbook, but for serious work I have a Linux partition I boot 
> into.  Virtualbox can be weird about USB, especially under OS-X where no-one 
> is really sure how things work (personally on my Snow Leopard late 2010 
> Macbook I've NEVER got a USB device to work under closed source VirtualBox).
> Does the live CD say anything if you type
> dmesg
> into a command window?
> You probably know this, but you've left it quite late in your project to sort 
> this out - if you want a reasonable chance of flying you'll need to get this 
> working ASAP.  The serial port trick means that at least your HW is fine 
> though.
> Did you install the udev rules into the live cd (you didn't specify which 
> one)?
> --G
> On Tue, 21 Dec 2010 23:40:52 -0000, James Spezeski <address@hidden> wrote:
>> Hi everyone, I'm trying to use Paparazzi for a University design project,
>> but I'm having serious problems getting started.  I'm using an OSX host
>> machine with a Ubuntu virtual machine.
>> For the Tiny 0.99, I used a USB <-> Serial converter and an LPC programmer
>> which was plugged into the serial port.  I tried programming it in USB mode
>> and serial mode and they both failed (no USB device found).  I did manage to
>> program it by connecting the the converter and creating a socket on the host
>> machine, then using that socket as a serial port on the guest machine and
>> programming it in serial mode, but I'm not sure why this worked and the
>> other approach didn't.
>> I also tried programming the TWOG with a cable I bought on PPZUAV, but the
>> host and guest machines both failed to even recognize that something was
>> plugged in.  I believe the bootloader is already installed, and the LED
>> flashes when I connect power.  I even tried booting from the live CD and I
>> had the same problem.
>> I've been stuck here for a couple months, so I would really appreciate any
>> help.
>> Thanks,
>>  James
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]