[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] trouble getting started...

From: Gareth Roberts
Subject: Re: [Paparazzi-devel] trouble getting started...
Date: Wed, 22 Dec 2010 00:34:30 -0000
User-agent: Opera Mail/11.00 (MacIntel)

I've got one kicking around based on Lucid (with a graphical SVN updator!! :D)
Don't have anywhere to host it though!

On Wed, 22 Dec 2010 00:33:05 -0000, Felix Ruess <address@hidden> wrote:

Also a word of caution about the live CDs. They are pretty old and out
of date, especially for the end user the configuration of the airframe
has changed quite a bit since then (all for the better of course ;-).
But otherwise you can of course still use them to check it out.
Of course if someone wants to make a more up to date live CD that
would be welcome :-D

Cheers, Felix

On Wed, Dec 22, 2010 at 1:21 AM, Gareth Roberts
<address@hidden> wrote:
Hi James,

Chris, I don't think there is an OSS version of Virtualbox for OSX, it's
amazing how much we take for granted in the linux world...

I've got a Macbook, but for serious work I have a Linux partition I boot
into. Virtualbox can be weird about USB, especially under OS-X where no-one
is really sure how things work (personally on my Snow Leopard late 2010
Macbook I've NEVER got a USB device to work under closed source VirtualBox).

Does the live CD say anything if you type
into a command window?

You probably know this, but you've left it quite late in your project to
sort this out - if you want a reasonable chance of flying you'll need to get
this working ASAP.  The serial port trick means that at least your HW is
fine though.

Did you install the udev rules into the live cd (you didn't specify which


On Tue, 21 Dec 2010 23:40:52 -0000, James Spezeski
<address@hidden> wrote:

Hi everyone, I'm trying to use Paparazzi for a University design project,
but I'm having serious problems getting started.  I'm using an OSX host
machine with a Ubuntu virtual machine.

For the Tiny 0.99, I used a USB <-> Serial converter and an LPC programmer
which was plugged into the serial port.  I tried programming it in USB
and serial mode and they both failed (no USB device found). I did manage
program it by connecting the the converter and creating a socket on the
machine, then using that socket as a serial port on the guest machine and
programming it in serial mode, but I'm not sure why this worked and the
other approach didn't.

I also tried programming the TWOG with a cable I bought on PPZUAV, but the host and guest machines both failed to even recognize that something was
plugged in.  I believe the bootloader is already installed, and the LED
flashes when I connect power. I even tried booting from the live CD and I
had the same problem.

I've been stuck here for a couple months, so I would really appreciate any


Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]