[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

shared libraries with g77

From: John W. Eaton
Subject: shared libraries with g77
Date: Wed, 3 Jun 1998 10:15:02 -0500 (CDT)

On  2-Jun-1998, Ruediger Back <address@hidden> wrote:

| has anybody succeeded in building shared libraries with g77 on Intel
| Linux ?


| It seems that the FORTRAN routines trigger a known bug in the
| current g77 compiler, which does not correctly compile with the PIC
| flag.

What version number?  I have no trouble compiling PIC code with g77  I realize that this is not the latest version, but it
works.  If there are bugs in newer versions of the compilers, please
report the problems to the g77 maintainers.  You are much more likely
to get the bugs fixed by reporting the problem to someone who can fix
the them rather than complaining about the problems here.

| Is there
| anybody with a dynamically linked octave on Linux (I'm sure there is)
| who can confirm that ?

Yes.  Many people do this.

| Basically Octave just keeps crashing right
| away - that is, after a certain input sequence which I send to
| bug-octave a few days ago. Strangely enough, the response I got was
| that my example was just working fine on a reference machine with a
| newer version. (2.0.12 while I had 2.0.11).
| So I compiled 2.0.13... still no good. I've also recently build my
| compiler, lib(g/c)++ using safe, tested version, so I'm sure that is
| not the problem (also built binutils). I tested versions compiled with
| both: pgcc (that is a pentium patched egcs compiler-suite gcc/g++/g77)
| as well as standard gcc/g++/g77. Same result. 

My guess is that you have some problem with your libraries or header
files (or both).  Do you have compatible versions of libc and
libstdc++?  Do the C++ header files match the version of libstdc++
that you have installed?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]