[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[help-GIFT] Re: Mac OS X installation

From: Niles Johnson
Subject: [help-GIFT] Re: Mac OS X installation
Date: Fri, 22 Jun 2007 10:35:51 -0500

Hello all,

I'm happy to say that the gift server seems to be working properly
now.  I tested a collection of just 3 images to see if I could
properly index the collection and start the gift server.  That seems
to run without error, although I haven't yet figured out how to get a
*client* to work.

While I'm waiting for a larger collection of images to be indexed, I
thought I would write my installation story, since it wasn't as simple
as following the suggestions of the previous e-mails in this thread
(although they were MUCH appreciated!).  I tried a variety of
different things, over several days, and unfortunately now I'm not
sure exactly why my installation worked :(  Hopefully this description
will still be useful to someone--I'm sorry it's so long, but I don't
understand it well enough to make it shorter :(


1. I tried Wolfgang's suggestion of removing CDomainSocket from the
appropriate  I'm not quite sure which one was the
"appropriate" one, but my first few guesses still produced errors
while compiling, so I decided to move on to Thomas's suggestion.

2. Since I had already removed malloc.h and values.h includes, I just added the
"#ifndef __APPLE__" and
around the offending block of code in GIFTServer/
This allowed me to make and install, but I had problems when I tried
to run ""

3. The problems I had with adding a collection were locale issues.  I
saw in a previous post that one mac user was able to run things
correctly by commenting out lines 705 and 713:
#    open LOCALELIST, "locale -m |" or die "$!";
#    open LOCALELIST, "locale LC_MONETARY |" or die "$!";
I tried this but still had a few problems

4. still complained because it had tried to
create its configuration file "gift-config.mrml", but because of the
previous errors, that file was not in the expected format.  When tried to backup this old file, it died because
it could not understand the file.  I tried deleting the file, but
still the script died.  Somewhere I found a sample copy of the config
file and copied that to my home directory.  Then finally proceeded through the indexing process without

5. Now I was ready to start gift!  Much to my dismay, it would not
start up, exiting with a bus error.  The output just before exiting

Could not link to symbol libGIFTAcPerl_getClassName:dlcompat: Symbol
"_libGIFTAcPerl_getClassName" not found
libGIFTAcPerl.0.0.0.dylib tested. Test FAILED.
Could not link to symbol libGIFTAcPerl_getClassName:dlcompat: Symbol
"_libGIFTAcPerl_getClassName" not found
libGIFTAcPerl.0.dylib tested. Test FAILED.
Could not link to symbol libGIFTAcPerl_getClassName:dlcompat: Symbol
"_libGIFTAcPerl_getClassName" not found
libGIFTAcPerl.a tested. Test FAILED.
Bus error

This lead me to think there was some problem with gift's interaction with perl.

6. I checked the ./configure output and noticed that the check for
whether gift could embed perl failed with an error about the "my_perl"
being undeclared (line 71 of "").

7. After some Google searching, I decided to try including XSUB.h to
"".  I had another error of the same sort,
so I also included XSUB.h in "libMRML/cc/".
Now when I ran ./configure, the test for embedding perl gave a warning
about an invalid conversion from one type to another, but succeeded.

8.  Unfortunately, during the make process then, I had a scary
sounding error about overriding something.  I don't remember this
exactly either (sorry), but I do know that it seemed similar to the
error mentioned in this thread:

((Somehow I also decided to include <bits/wordsize.h> in
"libMRML/cc/"--I don't remember exactly where in the
process this was, but somewhere around this time))

9. The thread mentioned in #8 said that the CVS version of gift
(0.1.15b?) had fixed a lot of bugs with perl embedding, so I decided
to give that a try.  Unfortunately I kept getting errors related to
missing library files, having to do with libGIFTQuInvertedFile,
libGIFTAcInvertedFile, and libGIFTAcURL2FTS.  I never could figure out
whether it was a .la file or a .dylib file that was missing, or how to
fix it.

10.  I decided the CVS code and the perl embedding weren't for me, but
I had read this thread in the meantime.  It suggested adding "LIBS =
-ldl" to "GIFTServer/", which I did:

11.  I tried goofing around again with the embedded perl (even though
I had resolved to give up on it), but after a while I removed the
XSUB.h inclusions I had made in #7.

((also at some stage I switched from just "./configure" to
"./configure --prefix=/Users/peachick/GIFT"))

12.  Then finally the "make" and "make install" ran successfully.  I
had also deleted 3 gift-* files from my home directory, and when I ran
the modified, it indexed successfully.

13.  I then executed the newly installed gift and now the output ends with:
TCP socket successfully initialized:8
TCP socket successfully initialized:9
Waiting for connection...

14. Hooray!!

P.S. The indexing has finished again, and I started gift successfully
again; still no luck with the client (I'm trying the one from; I've had to fiddle with it a little already, but
it's not showing any pictures so I'll have to look a little closer).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]