[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[help-GIFT] Mac OS X installation

From: Niles Johnson
Subject: [help-GIFT] Mac OS X installation
Date: Mon, 11 Jun 2007 16:54:44 -0500

Hello, I'm trying to install GIFT (0.1.14) for Mac OS 10.3.9

I've had a few problems, some of which I've (sort-of) resolved, and
some of which I haven't.  I'll try to give you the notable details
below--I hope my "solutions" haven't caused some new problems!

I first installed xpat and what I think are the necessary Perl
modules.  There were some problems with the XML::XQL::DOM module, but
I used "force install" from CPAN, and I think the components for GIFT
are installed correctly.

The 'configure' command runs without error, but I am getting errors
when I try to 'make'.

First I had the following error:
 "ppm_comment.c:3:20: malloc.h: No such file or directory"

I tried to correct this using Apple's porting suggestions at

They say that "malloc.h" is not supported, and that "stdlib.h" should
be used instead, so I removed the "#include malloc.h" lines from
"ppm_comment.c" and the other .c files in the same directory
("libSquirePPM").  Those suggestions also say that "limits.h" should
be used instead of "values.h", so I made that change in the file
"ppm_normalize.c".  (I didn't just dream that up--there was another
error notifying me of this missing file)

I know these changes should be made somehow through the makefile, but
since I don't yet know that these are correct changes, I haven't
thought more about that.

After these changes, the PPM section of the make process seems to
proceed without incident.  Later, however, I have another error:

In file included from
CTCPSocket.h:66: error: field `mSocketAddress' has incomplete type warning: #warning "threading blocked" In member function `virtual bool CSFGift::operator()(int)': error: invalid use of undefined type `struct sockaddr_in'
CTCPSocket.h:66: error: forward declaration of `struct sockaddr_in'
make[3]: *** [Server.o] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

I noticed that earlier versions of GIFT were intended to compile under
gcc 2.95, so I tried this using Apple's install of it, but have the
same errors.  I also tried gcc 3.1, with the same errors.

Beyond these futile attempts, I don't have any ideas how to proceed :(

thanks for any help you can give,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]