[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v7 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH v7 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument |
Date: |
Wed, 15 Jan 2025 13:50:21 +0100 |
Align the header file with the actual implementation of
this function, as the first argument is source ID and not
notification type.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
---
Changes from v8:
- Non-rename/cleanup changes merged altogether;
- source ID is now more generic, defined per guest target.
That should make easier to add support for 86.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
---
include/hw/acpi/ghes.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
index 20016c226d1f..50e3a25ea384 100644
--- a/include/hw/acpi/ghes.h
+++ b/include/hw/acpi/ghes.h
@@ -73,7 +73,7 @@ void acpi_build_hest(GArray *table_data, GArray
*hardware_errors,
const char *oem_id, const char *oem_table_id);
void acpi_ghes_add_fw_cfg(AcpiGhesState *vms, FWCfgState *s,
GArray *hardware_errors);
-int acpi_ghes_record_errors(uint8_t notify, uint64_t error_physical_addr);
+int acpi_ghes_record_errors(uint8_t source_id, uint64_t error_physical_addr);
/**
* acpi_ghes_present: Report whether ACPI GHES table is present
--
2.47.1
- [PATCH v7 00/16] Prepare GHES driver to support error injection, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 03/16] acpi/ghes: simplify the per-arch caller to build HEST table, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 01/16] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 13/16] acpi/ghes: better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 04/16] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 06/16] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 15/16] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 08/16] acpi/ghes: don't check if physical_address is not zero, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 12/16] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument,
Mauro Carvalho Chehab <=
- [PATCH v7 07/16] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 16/16] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 14/16] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 11/16] acpi/ghes: don't crash QEMU if ghes GED is not found, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 10/16] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 09/16] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2025/01/15