[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v7 15/16] acpi/ghes: Change ghes fill logic to work with only one
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH v7 15/16] acpi/ghes: Change ghes fill logic to work with only one source |
Date: |
Wed, 15 Jan 2025 13:50:31 +0100 |
Extending to multiple sources require a BIOS pointer to the
beginning of the HEST table, which in turn requires a backward-compatible
code.
So, the current code supports only one source. Ensure that and simplify
the code.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
---
hw/acpi/ghes.c | 12 ++++--------
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
index 8f59d327d3e5..b709c177cdea 100644
--- a/hw/acpi/ghes.c
+++ b/hw/acpi/ghes.c
@@ -387,15 +387,13 @@ static void get_hw_error_offsets(uint64_t ghes_addr,
* As the current version supports only one source, the ack offset is
* just sizeof(uint64_t).
*/
- *read_ack_register_addr = ghes_addr +
- ACPI_GHES_ERROR_SOURCE_COUNT * sizeof(uint64_t);
+ *read_ack_register_addr = ghes_addr + sizeof(uint64_t);
}
void ghes_record_cper_errors(const void *cper, size_t len,
uint16_t source_id, Error **errp)
{
uint64_t cper_addr = 0, read_ack_register_addr = 0, read_ack_register;
- uint64_t start_addr;
AcpiGedState *acpi_ged_state;
AcpiGhesState *ags;
@@ -412,11 +410,9 @@ void ghes_record_cper_errors(const void *cper, size_t len,
}
ags = &acpi_ged_state->ghes_state;
- start_addr = le64_to_cpu(ags->hw_error_le);
-
- start_addr += source_id * sizeof(uint64_t);
-
- get_hw_error_offsets(start_addr, &cper_addr, &read_ack_register_addr);
+ assert(ACPI_GHES_ERROR_SOURCE_COUNT == 1);
+ get_hw_error_offsets(le64_to_cpu(ags->hw_error_le),
+ &cper_addr, &read_ack_register_addr);
if (!cper_addr) {
error_setg(errp, "can not find Generic Error Status Block");
--
2.47.1
- [PATCH v7 00/16] Prepare GHES driver to support error injection, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 03/16] acpi/ghes: simplify the per-arch caller to build HEST table, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 01/16] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 13/16] acpi/ghes: better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 04/16] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 06/16] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 15/16] acpi/ghes: Change ghes fill logic to work with only one source,
Mauro Carvalho Chehab <=
- [PATCH v7 08/16] acpi/ghes: don't check if physical_address is not zero, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 12/16] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 07/16] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 16/16] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 14/16] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 11/16] acpi/ghes: don't crash QEMU if ghes GED is not found, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 10/16] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 09/16] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2025/01/15