[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v7 13/16] acpi/ghes: better name the offset of the hardware error
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH v7 13/16] acpi/ghes: better name the offset of the hardware error firmware |
Date: |
Wed, 15 Jan 2025 13:50:29 +0100 |
The hardware error firmware is where HEST error structures are
stored. Those can be GHESv2, but they can also be other types.
Better name the location of the hardware error.
No functional changes.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
---
hw/acpi/generic_event_device.c | 4 ++--
hw/acpi/ghes.c | 4 ++--
include/hw/acpi/ghes.h | 2 +-
3 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/hw/acpi/generic_event_device.c b/hw/acpi/generic_event_device.c
index 58540c0aaf26..c85d97ca3776 100644
--- a/hw/acpi/generic_event_device.c
+++ b/hw/acpi/generic_event_device.c
@@ -363,7 +363,7 @@ static const VMStateDescription vmstate_ghes = {
.version_id = 1,
.minimum_version_id = 1,
.fields = (const VMStateField[]) {
- VMSTATE_UINT64(ghes_addr_le, AcpiGhesState),
+ VMSTATE_UINT64(hw_error_le, AcpiGhesState),
VMSTATE_END_OF_LIST()
},
};
@@ -371,7 +371,7 @@ static const VMStateDescription vmstate_ghes = {
static bool ghes_needed(void *opaque)
{
AcpiGedState *s = opaque;
- return s->ghes_state.ghes_addr_le;
+ return s->ghes_state.hw_error_le;
}
static const VMStateDescription vmstate_ghes_state = {
diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
index 3f94a5542bb4..983e28505a08 100644
--- a/hw/acpi/ghes.c
+++ b/hw/acpi/ghes.c
@@ -359,7 +359,7 @@ void acpi_ghes_add_fw_cfg(AcpiGhesState *ags, FWCfgState *s,
/* Create a read-write fw_cfg file for Address */
fw_cfg_add_file_callback(s, ACPI_HW_ERROR_ADDR_FW_CFG_FILE, NULL, NULL,
- NULL, &(ags->ghes_addr_le), sizeof(ags->ghes_addr_le), false);
+ NULL, &(ags->hw_error_le), sizeof(ags->hw_error_le), false);
ags->present = true;
}
@@ -385,7 +385,7 @@ void ghes_record_cper_errors(const void *cper, size_t len,
}
ags = &acpi_ged_state->ghes_state;
- start_addr = le64_to_cpu(ags->ghes_addr_le);
+ start_addr = le64_to_cpu(ags->hw_error_le);
start_addr += source_id * sizeof(uint64_t);
diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
index 21666a4bcc8b..39619a2457cb 100644
--- a/include/hw/acpi/ghes.h
+++ b/include/hw/acpi/ghes.h
@@ -65,7 +65,7 @@ enum {
};
typedef struct AcpiGhesState {
- uint64_t ghes_addr_le;
+ uint64_t hw_error_le;
bool present; /* True if GHES is present at all on this board */
} AcpiGhesState;
--
2.47.1
- [PATCH v7 00/16] Prepare GHES driver to support error injection, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 03/16] acpi/ghes: simplify the per-arch caller to build HEST table, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 01/16] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 13/16] acpi/ghes: better name the offset of the hardware error firmware,
Mauro Carvalho Chehab <=
- [PATCH v7 04/16] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 06/16] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 15/16] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 08/16] acpi/ghes: don't check if physical_address is not zero, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 12/16] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 07/16] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 16/16] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 14/16] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2025/01/15