[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v7 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH v7 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code |
Date: |
Wed, 15 Jan 2025 13:50:18 +0100 |
Reduce the ident of the function and prepares it for
the next changes.
No functional changes.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
---
hw/acpi/ghes.c | 56 ++++++++++++++++++++++++++------------------------
1 file changed, 29 insertions(+), 27 deletions(-)
diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
index dc217694deb9..e66f3be1502b 100644
--- a/hw/acpi/ghes.c
+++ b/hw/acpi/ghes.c
@@ -402,40 +402,42 @@ int acpi_ghes_record_errors(uint8_t source_id, uint64_t
physical_address)
start_addr = le64_to_cpu(ags->ghes_addr_le);
- if (physical_address) {
+ if (!physical_address) {
+ return -1;
+ }
- if (source_id < ACPI_GHES_ERROR_SOURCE_COUNT) {
- start_addr += source_id * sizeof(uint64_t);
- }
+ if (source_id < ACPI_GHES_ERROR_SOURCE_COUNT) {
+ start_addr += source_id * sizeof(uint64_t);
+ }
- cpu_physical_memory_read(start_addr, &error_block_addr,
- sizeof(error_block_addr));
+ cpu_physical_memory_read(start_addr, &error_block_addr,
+ sizeof(error_block_addr));
- error_block_addr = le64_to_cpu(error_block_addr);
+ error_block_addr = le64_to_cpu(error_block_addr);
- read_ack_register_addr = start_addr +
- ACPI_GHES_ERROR_SOURCE_COUNT * sizeof(uint64_t);
+ read_ack_register_addr = start_addr +
+ ACPI_GHES_ERROR_SOURCE_COUNT * sizeof(uint64_t);
- cpu_physical_memory_read(read_ack_register_addr,
- &read_ack_register,
sizeof(read_ack_register));
+ cpu_physical_memory_read(read_ack_register_addr,
+ &read_ack_register, sizeof(read_ack_register));
- /* zero means OSPM does not acknowledge the error */
- if (!read_ack_register) {
- error_report("OSPM does not acknowledge previous error,"
- " so can not record CPER for current error anymore");
- } else if (error_block_addr) {
- read_ack_register = cpu_to_le64(0);
- /*
- * Clear the Read Ack Register, OSPM will write it to 1 when
- * it acknowledges this error.
- */
- cpu_physical_memory_write(read_ack_register_addr,
- &read_ack_register, sizeof(uint64_t));
+ /* zero means OSPM does not acknowledge the error */
+ if (!read_ack_register) {
+ error_report("OSPM does not acknowledge previous error,"
+ " so can not record CPER for current error anymore");
+ } else if (error_block_addr) {
+ read_ack_register = cpu_to_le64(0);
+ /*
+ * Clear the Read Ack Register, OSPM will write it to 1 when
+ * it acknowledges this error.
+ */
+ cpu_physical_memory_write(read_ack_register_addr,
+ &read_ack_register, sizeof(uint64_t));
- ret = acpi_ghes_record_mem_error(error_block_addr,
- physical_address);
- } else
- error_report("can not find Generic Error Status Block");
+ ret = acpi_ghes_record_mem_error(error_block_addr,
+ physical_address);
+ } else {
+ error_report("can not find Generic Error Status Block");
}
return ret;
--
2.47.1
- [PATCH v7 00/16] Prepare GHES driver to support error injection, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 03/16] acpi/ghes: simplify the per-arch caller to build HEST table, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 01/16] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 13/16] acpi/ghes: better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 04/16] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 06/16] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 15/16] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 08/16] acpi/ghes: don't check if physical_address is not zero, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code,
Mauro Carvalho Chehab <=
- [PATCH v7 12/16] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 07/16] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 16/16] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 14/16] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 11/16] acpi/ghes: don't crash QEMU if ghes GED is not found, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 10/16] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2025/01/15
- [PATCH v7 09/16] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2025/01/15