[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 15/25] qapi: Inline check_name() into check_union()
From: |
Markus Armbruster |
Subject: |
[PATCH 15/25] qapi: Inline check_name() into check_union() |
Date: |
Tue, 24 Sep 2019 15:28:20 +0200 |
check_name() consists of check_name_is_str() and check_name_str().
check_union() relies on the latter to catch optional discriminators.
The next commit will replace that by a more straightforward check.
Inlining check_name() into check_union() now should make that easier
to review.
Signed-off-by: Markus Armbruster <address@hidden>
---
scripts/qapi/common.py | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/scripts/qapi/common.py b/scripts/qapi/common.py
index 2dd794dfe7..f5599559ac 100644
--- a/scripts/qapi/common.py
+++ b/scripts/qapi/common.py
@@ -896,8 +896,10 @@ def check_union(expr, info):
# The value of member 'discriminator' must name a non-optional
# member of the base struct.
- check_name(discriminator, info,
- "discriminator of flat union '%s'" % name)
+ check_name_is_str(discriminator, info,
+ "discriminator of flat union '%s'" % name)
+ check_name_str(discriminator, info,
+ "discriminator of flat union '%s'" % name)
discriminator_value = base_members.get(discriminator)
if not discriminator_value:
raise QAPISemError(info,
--
2.21.0
- [PATCH 02/25] qapi: Rename .owner to .defined_in, (continued)
- [PATCH 02/25] qapi: Rename .owner to .defined_in, Markus Armbruster, 2019/09/24
- [PATCH 10/25] qapi: Use check_name_str() where it suffices, Markus Armbruster, 2019/09/24
- [PATCH 17/25] qapi: Move context-free checking to the proper place, Markus Armbruster, 2019/09/24
- [PATCH 11/25] qapi: Report invalid '*' prefix like any other invalid name, Markus Armbruster, 2019/09/24
- [PATCH 24/25] qapi: Improve reporting of redefinition, Markus Armbruster, 2019/09/24
- [PATCH 15/25] qapi: Inline check_name() into check_union(),
Markus Armbruster <=
- [PATCH 07/25] qapi: Improve reporting of member name clashes, Markus Armbruster, 2019/09/24
- [PATCH 13/25] qapi: Make check_type()'s array case a bit more obvious, Markus Armbruster, 2019/09/24
- [PATCH 18/25] qapi: Improve reporting of invalid 'if' errors, Markus Armbruster, 2019/09/24
- [PATCH 12/25] qapi: Move check for reserved names out of add_name(), Markus Armbruster, 2019/09/24
- [PATCH 22/25] qapi: Eliminate check_keys(), rename check_known_keys(), Markus Armbruster, 2019/09/24