[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

building Octave-3.4.2 on RedHat-5, the problem

From: Ахриев Альберт
Subject: building Octave-3.4.2 on RedHat-5, the problem
Date: Sat, 23 Jul 2011 01:27:37 +0400

Hi All,

I tried to build Octave-3.4.2 on RedHat-5.5, 64 bit with latest updates.
After successful compilation the executable crashes with segmentation fault.
Can anybody back me up on this?

First of all, I have installed all necessary packages.
Unfortunately, RedHat 5 (and 6) does not offer some packages (as well as Octave 
itself) in the official distribution,
but the limited functionality does work for me:

yum -y install gcc-c++.x86_64 gcc-gfortran.x86_64 gcc.x86_64 libgcc.x86_64

yum -y install binutils.x86_64 binutils-devel.x86_64 libstdc++*

yum -y install blas-static.x86_64 blas-devel.x86_64 blas.x86_64

yum -y install lapack-static.x86_64 lapack-devel.x86_64 lapack.x86_64

yum -y install texinfo.x86_64 texinfo-tex.x86_64 qhull-devel.x86_64 qhull.x86_64

yum -y install gperf.x86_64

yum -y install ncurses-devel.x86_64 ncurses-static.x86_64 ncurses-base.x86_64 
ncurses.x86_64 ncurses-term.x86_64

yum -y install GraphicsMagick.x86_64 GraphicsMagick-c++.x86_64 
GraphicsMagick-c++-devel.x86_64 GraphicsMagick-devel.x86_64

yum -y install readline-static.x86_64 readline-devel.x86_64 readline.x86_64

yum -y install suitesparse-static.x86_64 suitesparse-devel.x86_64 
suitesparse.x86_64 suitesparse-doc*

yum -y install flex.x86_64 flex-static.x86_64 bison.x86_64 bison-devel.x86_64 

yum -y install qrupdate.x86_64 qrupdate-devel.x86_64

yum -y install curl.x86_64 libcurl.x86_64 libcurl-devel.x86_64

yum -y install glpk.x86_64 glpk-devel.x86_64 glpk-static.x86_64 

yum -y install hdf5.x86_64 hdf5-devel.x86_64 hdf5-static.x86_64

yum -y install pcre-static.x86_64 pcre-devel.x86_64 pcre.x86_64

yum -y install mesa-libGL.x86_64 mesa-libGLU.x86_64 mesa-libGL-devel.x86_64 

yum -y install gnuplot.x86_64 gnuplot-common.x86_64 gnuplot-doc* gnuplot-latex*

yum -y install freetype-devel.x86_64 freetype.x86_64

yum -y install fltk-static.x86_64 fltk-devel.x86_64 fltk.x86_64

yum -y install fftw*

As I have mentioned before, some packages failed to install,
but ./configure script reports nothing suspicious -- just the functionality 
will be limited.
Second, to avoid compilation error related to documentation building and 
exclude the absent packages, I run the following script:

mkdir -p $HOME/soft/octave-3.4.2


/configure                     \
  --enable-docs=no              \
  --enable-64=no                \
  --disable-largefile           \
  --enable-openmp=no            \
  --enable-static=no            \
  --without-qhull               \
  --without-hdf5                \
  --without-fftw3               \
  --without-glpk                \
  --without-curl                \
  --without-opengl              \
  --without-framework-opengl    \
  --without-qrupdate            \
  --without-amd                 \
  --without-camd                \
  --without-colamd              \
  --without-ccolamd             \
  --without-cholmod             \
  --without-cxsparse            \
  --without-umfpack             \
Third, I run 'make' as usually and ... the resultant executable crashed with 
segmentation fault.

I would appreciate any suggestions, recommendations, etc.

I have managed to compile several instances of Octave-3.4.2 on Fedora 14 and 
15, 64 bit.
They work perfectly, however I need RedHat-5 installation to work on remote 
On the latest Ubuntu 64 bit I also got a problem with dependencies.

Thank you in advance,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]