[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with ginput

From: Matthias Brennwald
Subject: Re: Problem with ginput
Date: Thu, 10 Dec 2009 19:16:16 +0100

On Dec 10, 2009, at 3:21 PM, Ben Abbott wrote:

> On Thursday, December 10, 2009, at 08:52AM, "Matthias Brennwald" 
> <address@hidden> wrote:
>> On Dec 10, 2009, at 2:07 PM, Benjamin Lindner wrote:
>>>> using ginput() from the octave-forge plot package, octave
>>>> still hangs on calling ginput(1).
>>> Using the wxt terminal by issuing putenv("GNUTERM","wxt")
>>> it works
>>> octave> [x,y,b] = ginput(1)
>>> x =  5.1002
>>> y =  0.45119
>>> b =  1
>>> using the windows terminal it doesn't.
>>> I also see, that the windows terminal does *not*
>>> return after a mouse click, even when executing
>>> pause mouse any
>>> but only after a keypress.
>>> I see this in gnuplot 4.3.0-2009-07-08 CVS and in 4.4-rc1
>>> This looks like a gnuplot windows terminal issue.
>>> benjamin
>> I tried your example with the wxt terminal, but I still get the same 
>> behavior from ginput(...) on my Windows box.
>> Matthias
> Please verify that you are using the ginput form Octave's core.
> What does "which ginput" say?
> If the version in Octave's core doesn't work, have you tried the one from the 
> Octave-Forge plot package?

Aha!!! Here's what I did:
- I had the feeling that maybe I messed up with the Octave m-files when I tried 
to apply the patch discussed earlier, so I uninstalled Octave and reinstalled 
it completely. I did NOT choose to install any Octave-forge packages.
- I tried again, and this time ginput seemed to work. This is the Octave-core 
ginput (as confirmed by which ginput).
- Re-reading my initial post I found that with my previously installed Octave, 
the ginput I used was the one from the plot package.

- The ginput from the plot package seems to have a problem.
- Why are there two different ginputs (One in Octave core, the other in Octave 
forge)? This is at least confusing. But I think it's a rather bad idea to have 
different commands with the same name, because code using such commands may not 
work in the same on different machines (as was the case here).
- Is there a way to make sure (in my code) that the ginput from Octave core is 
used, not the one from the plot package?

> I checked the gnuplot 4.3 manual, mousing with the Windows terminal should 
> work. However, perhaps it is a good idea to verify. Please run gnuplot and 
> try ...

I am a Windows noob. How do I run gnuplot on Windows?

> gnuplot> set term windows
> gnuplot> plot sin(x)
> gnuplot> pause mouse
> gnuplot> print MOUSE_X         
> gnuplot> print MOUSE_Y
> Ben

Matthias Brennwald, Käferholzstrasse 173, CH-8046 Zürich, +41 44 364 17 03

reply via email to

[Prev in Thread] Current Thread [Next in Thread]