[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: path: octave 3.0.0 can't find itself

From: Dushan Mitrovich
Subject: Re: path: octave 3.0.0 can't find itself
Date: Thu, 27 Dec 2007 23:10:49 -0700
User-agent: VSoup v1.2.9.48Beta [OS/2]

Dushan Mitrovich <address@hidden> wrote:
>"John W. Eaton" <address@hidden> wrote:
>>On 27-Dec-2007, Ben Abbott wrote:
>>| The solution that worked for me was to delete the .octaverc file
>>| altogether. I doubt this is a desirable solution for all cases, but
>>| if you don't have any information that is local to your setup, I'd
>>| recommend deleting the .octaverc file.
>> Why is there any version-specific path info in your ~/.octaverc file?
>> Did you add it by hand?  If so, why?
> That's puzzled me too.  I don't know the answer, but here's my best
> guess: When muddling thru my initial setup of Octave on my still-un-
> familiar OSX, I had done some un-necessary steps that tripped me up
> on this occasion.  What that means is that I have still got unneeded
> references (to 3.0.0) in .octaverc that do no harm now but are poised
> to trip me on the next go-around.  I'll try deleting all these refe-
> rences in the file and see what happens.  And I'll also try deleting
> the file altogether, starting Octave, then re-specifying the location
> of my personal Octave files.

I now tried both these approaches, and determined that the version-
specific references seem to be necessary:

# After deleting the .octaverc file, Octave runs but doesn't know where
  my personal files are.

# If I retain the .octaverc file but shorn of all version-specific refe-
  rences, Octave runs and knows where my personal files are, but can't
  find its own files, e.g. 'repmat'.  As Ben pointed out, the .dmg file
  I downloaded from has the following version-specific direc-
  tory organization in OSX:


  (There are a lot more directories in, but they are not
  version-specific.)  The Octave .m files are in the /m directory under
  the last listed path above, which is included in the .octaverc file.
  But the first three paths are not included, making me wonder what, if
  anything, is missing when I use Octave.

- Dushan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]