[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.9.4 on mac OSX tiger

From: Marius Schamschula
Subject: Re: 2.9.4 on mac OSX tiger
Date: Sat, 21 Jan 2006 13:04:00 -0600

On Jan 21, 2006, at 11:53 AM, Joe Koski wrote:


Great work! Sorry, but I don't have an answer to your .dylib question. You
might try posting it to the Apple unix-porting list

to see if they have an answer. Most of your libreadline.dylib versions are
in the Fink directory, or are installed into /usr/local/lib, so it appears
that the one with the missing symbol is Apple's /usr/lib version. When you
move the /usr/lib version out of the way, then the linker probably finds the
/usr/local/lib version that works.

For what it's worth, on my OS X 10.3.9, I don't have a
/usr/lib/libreadline.dylib; I only have /usr/local/lib/libreadline.a
installed, and I don't recall when or how it got installed, since that
directory is usually empty on a new Mac installation.

See my previous post. /usr/lib/libreadline.dylib is a Mac OS X 10.4.x thing, not to be found in 10.3.9. It is NOT gnu readline compatible. There are a number of other such annoyances in Tiger, such as /usr/bin/locale and a few others.

Which Fortran compiler did you use, perhaps gfortran? Installed via .dmg
from the website?


on 1/21/06 9:19 AM, Carlo de Falco at address@hidden wrote:

I just managed to compile octave 2.9.4
on my ibook g3 running osx 10.4.4 with the
configuration options in the attached file
and it seems to work
quite fine exept that I couldn't manage
to link it to libreadline.
Configure crashes complaining  that

libreadline.dylib does not contain symbol

actually I have many instances of readline:


and all contain the required symbol
exept /usr/lib/libreadline.dylib

I tried adding paths to other libraries in
the linker flags:

LDFLAGS="-L/usr/local/lib -L/sw/lib"

but it still tries to link to wrong version.

As a workaround I tried to move
/usr/lib/libreadline.dylib to
a different position and configure goes fine,
but what would happen if I put it back in place
after compiling?

Thanks a lot in advance for any help,

P.S. To let make work in the documentation
directory I had to patch the makefile (a missing semicolon)
but I don't know if I should submit this as a bug
as I didn't use the CVS version.



Marius Schamschula                               Webmaster

        The Huntsville Macintosh Users Group


webmaster at hmug dot org    marius at schamschula dot com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]