[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.9.4 on mac OSX tiger

From: Marius Schamschula
Subject: Re: 2.9.4 on mac OSX tiger
Date: Sat, 21 Jan 2006 11:29:28 -0600

On Jan 21, 2006, at 10:19 AM, Carlo de Falco wrote:

I just managed to compile octave 2.9.4
on my ibook g3 running osx 10.4.4 with the
configuration options in the attached file
and it seems to work
quite fine exept that I couldn't manage
to link it to libreadline.
Configure crashes complaining  that

libreadline.dylib does not contain symbol

actually I have many instances of readline:


and all contain the required symbol
exept /usr/lib/libreadline.dylib

This is Apple's non-standard version of libreadline. You need to hide it from any package that may want to link against it. I.e.:

sudo mv /usr/lib/libreadline.dylib /usr/lib/

Don't forget to return it to its original name after you are done.

I tried adding paths to other libraries in
the linker flags:

LDFLAGS="-L/usr/local/lib -L/sw/lib"

but it still tries to link to wrong version.

As a workaround I tried to move
/usr/lib/libreadline.dylib to
a different position and configure goes fine,
but what would happen if I put it back in place
after compiling?

Thanks a lot in advance for any help,

P.S. To let make work in the documentation
directory I had to patch the makefile (a missing semicolon)
but I don't know if I should submit this as a bug
as I didn't use the CVS version.

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]