[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Release of Enigma 1.30-alpha

From: ZockDom
Subject: Re: Release of Enigma 1.30-alpha
Date: Thu, 24 Dec 2020 10:40:29 +0100

Well, I‘ve been running Enigma successfully. Since you asked for possible 
I built Enigma from the tar archive and everything seems to work fine. I‘m 
running Manjaro Linux with kernel 5.9.11. Enigma is linked against 
libSDL2-2.0.so.0 (package version 2.0.12-3), ..._image (2.0.5-2), ..._mixer 
(2.0.4-5), ..._ttf (2.0.15-2), libjpeg.so.8 (libjpeg-turbo 2.0.6-1), 
libtiff.so.5.5.0 (package version 4.1.0) and libpng16.so.16 (package version 
Maybe differences there might cause the bug you describe.

> Am 24.12.2020 um 05:11 schrieb Sidney Markowitz <sidney@sidney.com>:
> So far I have tried building it on VirtualBox virtual machines with CentOS 
> 7, Ubuntu 18.04.5LTS, and Ubuntu 20.04LTS, all with VirtualBox Guest 
> Additions installed, and I have both built from the working directory from 
> the repo with autogen.sh, configure, make gmo, make, sudo make install, sudo 
> enigma --makepreview being run, and also tried creating a distribution tar.gz 
> and building from that (no additional autogen.sh, make gmo, or makepreview).
> In every case, I ran it by running the command "enigma" in a Terminal command 
> line. It started up ok, including being able to use the mouse to select menu 
> items, up until I clicked on a level to run it. When in a level, moving the 
> mouse caused lines of output on the Terminal saying (with varying numbers)
>  mouse event with 33320, 14986
> but the ball did not move. Clicking the mouse did cause the correct response 
> in the game for a mouse click.
> Pressing the Esc key properly escaped the level and the magic wand mouse 
> cursor did then appear and worked to select from the menu.
> Has anyone else had a similar experience, or can say what is different in 
> your setup if you have been successful running in Linux, or do you have any 
> insight on the mouse event messages and the inability to use the mouse in the 
> levels?
> Thanks,
> Sidney
> Sidney Markowitz wrote on 24/12/20 10:12 am:
>> What version of Linux did you use and how did you build it? I guess you built
>> from the git master branch? I tried making a release 1.30-alpha tar.gz and
>> building from that on CentOS 7 and on Ubuntu 18.04 and on both of them the
>> mouse was not responsive once I started a level.
>>  Sidney
>> Fòram na Gàidhlig wrote on 24/12/20 7:51 am:
>>> Thanks!
>>> I have given it a quick spin on Linux and it seems to be working fine.
>>> Need to brush up on my dexterity now!
>>> Can you update the translation files on Transifex soon? It would also be
>>> good if the strings were sorted by file occurrence rather than
>>> alphabetically, to give translators some context.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]