[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Release of Enigma 1.30-alpha

From: Fòram na Gàidhlig
Subject: Re: Release of Enigma 1.30-alpha
Date: Thu, 24 Dec 2020 09:39:21 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.10.0

I'm on an Ubuntu 20.04-based Linux Mint Mate. I ran:

sudo make install (needed for translations)

Running ./enigma or enigma worked fine.

I was missing some dependencies initially, so just to be sure I can
"make clean" in between attempts.

This is my ./configure summary:

   Source directory:    .
   Installation prefix: /usr/local
   C++ compiler:        g++ -g -O2 -DENABLE_ASSERT -g -DCXXLUA
   Libraries:           -lcurl -lxerces-c -lpng -ldl
   Linker options:
   Languages:           de fr nl it es sv ru hu pt fi uk be el pl cs gd hr sk da
   System enet:         no

Compiler: gcc (Ubuntu 9.3.0-17ubuntu1~20.04) 9.3.0

If you're on a VirtualBox, maybe there is a driver issue?

Sgrìobh Sidney Markowitz na leanas 24/12/2020 aig 04:11:
> So far I have tried building it on VirtualBox virtual machines with
> CentOS 7, Ubuntu 18.04.5LTS, and Ubuntu 20.04LTS, all with VirtualBox
> Guest Additions installed, and I have both built from the working
> directory from the repo with autogen.sh, configure, make gmo, make, sudo
> make install, sudo enigma --makepreview being run, and also tried
> creating a distribution tar.gz and building from that (no additional
> autogen.sh, make gmo, or makepreview).
> In every case, I ran it by running the command "enigma" in a Terminal
> command line. It started up ok, including being able to use the mouse to
> select menu items, up until I clicked on a level to run it. When in a
> level, moving the mouse caused lines of output on the Terminal saying
> (with varying numbers)
>    mouse event with 33320, 14986
> but the ball did not move. Clicking the mouse did cause the correct
> response in the game for a mouse click.
> Pressing the Esc key properly escaped the level and the magic wand mouse
> cursor did then appear and worked to select from the menu.
> Has anyone else had a similar experience, or can say what is different
> in your setup if you have been successful running in Linux, or do you
> have any insight on the mouse event messages and the inability to use
> the mouse in the levels?
> Thanks,
>  Sidney
> Sidney Markowitz wrote on 24/12/20 10:12 am:
>> What version of Linux did you use and how did you build it? I guess
>> you built
>> from the git master branch? I tried making a release 1.30-alpha tar.gz
>> and
>> building from that on CentOS 7 and on Ubuntu 18.04 and on both of them
>> the
>> mouse was not responsive once I started a level.
>>    Sidney
>> Fòram na Gàidhlig wrote on 24/12/20 7:51 am:
>>> Thanks!
>>> I have given it a quick spin on Linux and it seems to be working fine.
>>> Need to brush up on my dexterity now!
>>> Can you update the translation files on Transifex soon? It would also be
>>> good if the strings were sorted by file occurrence rather than
>>> alphabetically, to give translators some context.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]