[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Mario Marietto
Subject: https://superuser.com/questions/1691407/trying-to-passthru-my-rtx-2080-ti-to-a-windows-7-x64-bit-vm-using-virt-manager-o
Date: Mon, 6 Dec 2021 15:12:12 +0100


I would like to virtualize Windows 7 x64 bit passing through my graphic card (rtx 2080 ti) with qemu-kvm on Ubuntu 21.10. It's failing for me,so I'm trying to understand what's wrong.

This is only an intermediate project. The main project that I'm working on is related to bhyve. I would like to gather information about the reasons why windows 10 does not accept my passed thru nvidia graphic card,since it gives error 43. But to achieve this,I've thought about virtualizing windows 7 with qemu. I need to understand what is needed. The same components needed should find a similarity in the bhyve code. I'm not sure that I will be able to understand what's wrong inside bhyve in relation with windows 10,but maybe I can be able to pass thru my graphic card within windows 7 in qemu and in bhyve,because windows 7 is older than windows 10 and theoretically less complicated. I'm walking down a steep road that starts from afar,trying to understand much more about what's needed to make "things" work. I'm sure that my graphic card if passed through in a windows 10 with bhyve can't be used,but I'm not sure that it will not work also with windows 7. My sensation is that it could work. I want to be sure of this. If it works,it will be positive because it is always better to reach a small goal than to don't reach anything at all. With my graphic card passed and working in windows 7 I will send for sure an email to the virtualization ML,explaining what's needed to reach the goal and asking if bhyve has something similar and how to use it.

After several modifications to the xml code of libvirt suggested by a very nice reddit user,that you can read here :


I ended up with this configuration :


Unfortunately in UEFI mode windows 7 freezes on its logo,even if it is able to connect to the net. While in BIOS mode my monitor does not turn on at all.

I've installed the ssh server inside windows 7 and from Linux I tried to connect to that server and I've issued the following command :

mario@MARIETTO-PC C:\Users\mario>wmic path win32_videocontroller get configmanagererrorcode

because I wanted to check the status of my graphic card inside windows 7. I mean,which error it shows. As you can see it seems to be 12. So,it seems that my rtx 2080 ti even without the default graphic adapter (-vga none),it does not work,reporting error 12.

Error 12 : The “This device cannot find enough free that it can use (Code 12)” problem is displayed within the device’s properties windows in the Device status box. That error is usually a hardware conflict which arises when two devices are assigned the same I/O port but there are other culprits as well.

At first I thought that the error 12 was caused by the presence of the default graphic display adapter,but it seems that the cause is another one,because it is still present if I use "-vga none".

I've googled a little bit and maybe I found the fix for this error in this site :


where he says :

My system has a very similar setup that was giving me the same code 12 error. I have been able to get it working with the following setting in virt-manager: CPUs -> Model -> Haswell-noTSX-IBRS Using the "Copy host CPU configuration" appeared to give me issues.

even if I'm not sure that it will fix the error,I tried,but another error happened :



reply via email to

[Prev in Thread] Current Thread [Next in Thread]