[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v8 12/15] hw/pci: Replace -1 with UINT32_MAX for romsize
From: |
Akihiko Odaki |
Subject: |
[PATCH v8 12/15] hw/pci: Replace -1 with UINT32_MAX for romsize |
Date: |
Wed, 28 Feb 2024 20:33:23 +0900 |
romsize is an uint32_t variable. Specifying -1 as an uint32_t value is
obscure way to denote UINT32_MAX.
Worse, if int is wider than 32-bit, it will change the behavior of a
construct like the following:
romsize = -1;
if (romsize != -1) {
...
}
When -1 is assigned to romsize, -1 will be implicitly casted into
uint32_t, resulting in UINT32_MAX. On contrary, when evaluating
romsize != -1, romsize will be casted into int, and it will be a
comparison of UINT32_MAX and -1, and result in false.
Replace -1 with UINT32_MAX for statements involving the variable to
clarify the intent and prevent potential breakage.
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
Reviewed-by: Markus Armbruster <armbru@redhat.com>
---
hw/pci/pci.c | 8 ++++----
hw/xen/xen_pt_load_rom.c | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/hw/pci/pci.c b/hw/pci/pci.c
index 54b375da2d26..84df07a2789b 100644
--- a/hw/pci/pci.c
+++ b/hw/pci/pci.c
@@ -70,7 +70,7 @@ static bool pcie_has_upstream_port(PCIDevice *dev);
static Property pci_props[] = {
DEFINE_PROP_PCI_DEVFN("addr", PCIDevice, devfn, -1),
DEFINE_PROP_STRING("romfile", PCIDevice, romfile),
- DEFINE_PROP_UINT32("romsize", PCIDevice, romsize, -1),
+ DEFINE_PROP_UINT32("romsize", PCIDevice, romsize, UINT32_MAX),
DEFINE_PROP_UINT32("rombar", PCIDevice, rom_bar, 1),
DEFINE_PROP_BIT("multifunction", PCIDevice, cap_present,
QEMU_PCI_CAP_MULTIFUNCTION_BITNR, false),
@@ -2073,7 +2073,7 @@ static void pci_qdev_realize(DeviceState *qdev, Error
**errp)
g_cmp_uint32, NULL);
}
- if (pci_dev->romsize != -1 && !is_power_of_2(pci_dev->romsize)) {
+ if (pci_dev->romsize != UINT32_MAX && !is_power_of_2(pci_dev->romsize)) {
error_setg(errp, "ROM size %u is not a power of two",
pci_dev->romsize);
return;
}
@@ -2359,7 +2359,7 @@ static void pci_add_option_rom(PCIDevice *pdev, bool
is_default_rom,
return;
}
- if (load_file || pdev->romsize == -1) {
+ if (load_file || pdev->romsize == UINT32_MAX) {
path = qemu_find_file(QEMU_FILE_TYPE_BIOS, pdev->romfile);
if (path == NULL) {
path = g_strdup(pdev->romfile);
@@ -2378,7 +2378,7 @@ static void pci_add_option_rom(PCIDevice *pdev, bool
is_default_rom,
pdev->romfile);
return;
}
- if (pdev->romsize != -1) {
+ if (pdev->romsize != UINT_MAX) {
if (size > pdev->romsize) {
error_setg(errp, "romfile \"%s\" (%u bytes) "
"is too large for ROM size %u",
diff --git a/hw/xen/xen_pt_load_rom.c b/hw/xen/xen_pt_load_rom.c
index 03422a8a7148..6bc64acd3352 100644
--- a/hw/xen/xen_pt_load_rom.c
+++ b/hw/xen/xen_pt_load_rom.c
@@ -53,7 +53,7 @@ void *pci_assign_dev_load_option_rom(PCIDevice *dev,
}
fseek(fp, 0, SEEK_SET);
- if (dev->romsize != -1) {
+ if (dev->romsize != UINT_MAX) {
if (st.st_size > dev->romsize) {
error_report("ROM BAR \"%s\" (%ld bytes) is too large for ROM size
%u",
rom_file, (long) st.st_size, dev->romsize);
--
2.43.2
- RE: [PATCH v8 02/15] pcie_sriov: Validate NumVFs, (continued)
- [PATCH v8 05/15] hw/pci: Always call pcie_sriov_pf_reset(), Akihiko Odaki, 2024/02/28
- [PATCH v8 04/15] pcie_sriov: Do not reset NumVFs after disabling VFs, Akihiko Odaki, 2024/02/28
- [PATCH v8 07/15] pcie_sriov: Do not manually unrealize, Akihiko Odaki, 2024/02/28
- [PATCH v8 06/15] hw/pci: Rename has_power to enabled, Akihiko Odaki, 2024/02/28
- [PATCH v8 08/15] pcie_sriov: Reuse SR-IOV VF device instances, Akihiko Odaki, 2024/02/28
- [PATCH v8 09/15] pcie_sriov: Release VFs failed to realize, Akihiko Odaki, 2024/02/28
- [PATCH v8 10/15] pcie_sriov: Remove num_vfs from PCIESriovPF, Akihiko Odaki, 2024/02/28
- [PATCH v8 11/15] pcie_sriov: Register VFs after migration, Akihiko Odaki, 2024/02/28
- [PATCH v8 12/15] hw/pci: Replace -1 with UINT32_MAX for romsize,
Akihiko Odaki <=
- [PATCH v8 13/15] hw/pci: Use UINT32_MAX as a default value for rombar, Akihiko Odaki, 2024/02/28
- [PATCH v8 14/15] hw/pci: Determine if rombar is explicitly enabled, Akihiko Odaki, 2024/02/28
- [PATCH v8 15/15] hw/qdev: Remove opts member, Akihiko Odaki, 2024/02/28