[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v8 05/15] hw/pci: Always call pcie_sriov_pf_reset()
From: |
Akihiko Odaki |
Subject: |
[PATCH v8 05/15] hw/pci: Always call pcie_sriov_pf_reset() |
Date: |
Wed, 28 Feb 2024 20:33:16 +0900 |
Call pcie_sriov_pf_reset() from pci_do_device_reset() just as we do
for msi_reset() and msix_reset() to prevent duplicating code for each
SR-IOV PF.
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
---
hw/net/igb.c | 2 --
hw/nvme/ctrl.c | 4 ----
hw/pci/pci.c | 1 +
3 files changed, 1 insertion(+), 6 deletions(-)
diff --git a/hw/net/igb.c b/hw/net/igb.c
index 9345506f81ec..9b37523d6df8 100644
--- a/hw/net/igb.c
+++ b/hw/net/igb.c
@@ -488,12 +488,10 @@ static void igb_pci_uninit(PCIDevice *pci_dev)
static void igb_qdev_reset_hold(Object *obj)
{
- PCIDevice *d = PCI_DEVICE(obj);
IGBState *s = IGB(obj);
trace_e1000e_cb_qdev_reset_hold();
- pcie_sriov_pf_reset(d);
igb_core_reset(&s->core);
}
diff --git a/hw/nvme/ctrl.c b/hw/nvme/ctrl.c
index 7c0d3f108724..c1af4b87b34a 100644
--- a/hw/nvme/ctrl.c
+++ b/hw/nvme/ctrl.c
@@ -7114,10 +7114,6 @@ static void nvme_ctrl_reset(NvmeCtrl *n, NvmeResetType
rst)
sctrl = &n->sec_ctrl_list.sec[i];
nvme_virt_set_state(n, le16_to_cpu(sctrl->scid), false);
}
-
- if (rst != NVME_RESET_CONTROLLER) {
- pcie_sriov_pf_reset(pci_dev);
- }
}
if (rst != NVME_RESET_CONTROLLER) {
diff --git a/hw/pci/pci.c b/hw/pci/pci.c
index 6496d027ca61..e7a39cb203ae 100644
--- a/hw/pci/pci.c
+++ b/hw/pci/pci.c
@@ -409,6 +409,7 @@ static void pci_do_device_reset(PCIDevice *dev)
msi_reset(dev);
msix_reset(dev);
+ pcie_sriov_pf_reset(dev);
}
/*
--
2.43.2
- [PATCH v8 00/15] hw/pci: SR-IOV related fixes and improvements, Akihiko Odaki, 2024/02/28
- [PATCH v8 01/15] hw/nvme: Use pcie_sriov_num_vfs(), Akihiko Odaki, 2024/02/28
- [PATCH v8 03/15] pcie_sriov: Reset SR-IOV extended capability, Akihiko Odaki, 2024/02/28
- [PATCH v8 02/15] pcie_sriov: Validate NumVFs, Akihiko Odaki, 2024/02/28
- [PATCH v8 05/15] hw/pci: Always call pcie_sriov_pf_reset(),
Akihiko Odaki <=
- [PATCH v8 04/15] pcie_sriov: Do not reset NumVFs after disabling VFs, Akihiko Odaki, 2024/02/28
- [PATCH v8 07/15] pcie_sriov: Do not manually unrealize, Akihiko Odaki, 2024/02/28
- [PATCH v8 06/15] hw/pci: Rename has_power to enabled, Akihiko Odaki, 2024/02/28
- [PATCH v8 08/15] pcie_sriov: Reuse SR-IOV VF device instances, Akihiko Odaki, 2024/02/28
- [PATCH v8 09/15] pcie_sriov: Release VFs failed to realize, Akihiko Odaki, 2024/02/28
- [PATCH v8 10/15] pcie_sriov: Remove num_vfs from PCIESriovPF, Akihiko Odaki, 2024/02/28
- [PATCH v8 11/15] pcie_sriov: Register VFs after migration, Akihiko Odaki, 2024/02/28
- [PATCH v8 12/15] hw/pci: Replace -1 with UINT32_MAX for romsize, Akihiko Odaki, 2024/02/28
- [PATCH v8 13/15] hw/pci: Use UINT32_MAX as a default value for rombar, Akihiko Odaki, 2024/02/28