qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 1/5] tests/9pfs: Factor out do_fs_version() helper


From: Greg Kurz
Subject: Re: [PATCH 1/5] tests/9pfs: Factor out do_fs_version() helper
Date: Tue, 20 Oct 2020 17:41:56 +0200

On Tue, 20 Oct 2020 17:34:05 +0200
Christian Schoenebeck <qemu_oss@crudebyte.com> wrote:

> On Dienstag, 20. Oktober 2020 17:11:05 CEST Greg Kurz wrote:
> > fs_version() is a top level test function. Factor out the sugar
> > to a separate helper instead of hijacking it in other tests.
> > 
> > Signed-off-by: Greg Kurz <groug@kaod.org>
> > ---
> >  tests/qtest/virtio-9p-test.c |   14 +++++++++-----
> >  1 file changed, 9 insertions(+), 5 deletions(-)
> > 
> > diff --git a/tests/qtest/virtio-9p-test.c b/tests/qtest/virtio-9p-test.c
> > index c15908f27b3d..63f91aaf77e6 100644
> > --- a/tests/qtest/virtio-9p-test.c
> > +++ b/tests/qtest/virtio-9p-test.c
> > @@ -567,10 +567,8 @@ static void v9fs_rflush(P9Req *req)
> >      v9fs_req_free(req);
> >  }
> > 
> > -static void fs_version(void *obj, void *data, QGuestAllocator *t_alloc)
> > +static void do_fs_version(QVirtio9P *v9p)
> >  {
> > -    QVirtio9P *v9p = obj;
> > -    alloc = t_alloc;
> >      const char *version = "9P2000.L";
> >      uint16_t server_len;
> >      char *server_version;
> > @@ -585,13 +583,19 @@ static void fs_version(void *obj, void *data,
> > QGuestAllocator *t_alloc) g_free(server_version);
> >  }
> 
> So the naming convention from now on shall be do_fs_*() for non-toplevel 
> functions there. Not that I care too much about the precise prefix, but how 
> about just do_*() for them instead?
> 

I've prepended "do_" to the existing names by pure laziness but I'm
fine with any prefix or naming convention actually.

So just tell me what you prefer and I'll send a v2.

> Except of that, your patches look fine to me.
> 
> Best regards,
> Christian Schoenebeck
> 
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]