[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 32/54] ps2: use ps2_raise_irq() instead of calling update_irq(
From: |
Mark Cave-Ayland |
Subject: |
[PATCH v2 32/54] ps2: use ps2_raise_irq() instead of calling update_irq() directly |
Date: |
Fri, 24 Jun 2022 14:40:47 +0100 |
This consolidates the logic of raising the PS2 IRQ into one single function.
Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
Acked-by: Helge Deller <deller@gmx.de>
Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
---
hw/input/ps2.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/hw/input/ps2.c b/hw/input/ps2.c
index 24c9853d37..a14281bc54 100644
--- a/hw/input/ps2.c
+++ b/hw/input/ps2.c
@@ -557,7 +557,7 @@ uint32_t ps2_read_data(PS2State *s)
s->update_irq(s->update_arg, 0);
/* reassert IRQs if data left */
if (q->count) {
- s->update_irq(s->update_arg, 1);
+ ps2_raise_irq(s);
}
}
return val;
--
2.30.2
- [PATCH v2 24/54] pckbd: add size qdev property to I8042_MMIO device, (continued)
- [PATCH v2 24/54] pckbd: add size qdev property to I8042_MMIO device, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 25/54] pckbd: implement i8042_mmio_realize() function, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 26/54] pckbd: implement i8042_mmio_init() function, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 27/54] pckbd: alter i8042_mm_init() to return a I8042_MMIO device, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 28/54] pckbd: move mapping of I8042_MMIO registers to MIPS magnum machine, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 29/54] pckbd: more vmstate_register() from i8042_mm_init() to i8042_mmio_realize(), Mark Cave-Ayland, 2022/06/24
- [PATCH v2 30/54] pckbd: move ps2_kbd_init() and ps2_mouse_init() to i8042_mmio_realize(), Mark Cave-Ayland, 2022/06/24
- [PATCH v2 31/54] ps2: make ps2_raise_irq() function static, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 32/54] ps2: use ps2_raise_irq() instead of calling update_irq() directly,
Mark Cave-Ayland <=
- [PATCH v2 33/54] ps2: introduce ps2_lower_irq() instead of calling update_irq() directly, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 34/54] ps2: add gpio for output IRQ and optionally use it in ps2_raise_irq() and ps2_lower_irq(), Mark Cave-Ayland, 2022/06/24
- [PATCH v2 35/54] pckbd: replace irq_kbd and irq_mouse with qemu_irq array in KBDState, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 38/54] lasips2: QOMify LASIPS2State, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 37/54] pl050: add QEMU interface comment, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 36/54] pl050: switch over from update_irq() function to PS2 device gpio, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 39/54] lasips2: move lasips2 QOM types from lasips2.c to lasips2.h, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 40/54] lasips2: rename lasips2_init() to lasips2_initfn() and update it to return the LASIPS2 device, Mark Cave-Ayland, 2022/06/24