[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 40/54] lasips2: rename lasips2_init() to lasips2_initfn() and
From: |
Mark Cave-Ayland |
Subject: |
[PATCH v2 40/54] lasips2: rename lasips2_init() to lasips2_initfn() and update it to return the LASIPS2 device |
Date: |
Fri, 24 Jun 2022 14:40:55 +0100 |
When QOMifying a device it is typical to use _init() as the suffix for an
instance_init function, however this name is already in use by the legacy
LASIPS2
wrapper function. Eventually the wrapper function will be removed, but for now
rename it to lasips2_initfn() to avoid a naming collision.
At the same time update lasips2_initfn() return the LASIPS2 device so that it
can later be accessed using qdev APIs by the HPPA machine.
Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
Acked-by: Helge Deller <deller@gmx.de>
Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
---
hw/hppa/machine.c | 4 ++--
hw/input/lasips2.c | 6 ++++--
include/hw/input/lasips2.h | 3 ++-
3 files changed, 8 insertions(+), 5 deletions(-)
diff --git a/hw/hppa/machine.c b/hw/hppa/machine.c
index 63b9dd2396..72677aeb2a 100644
--- a/hw/hppa/machine.c
+++ b/hw/hppa/machine.c
@@ -280,8 +280,8 @@ static void machine_hppa_init(MachineState *machine)
}
/* PS/2 Keyboard/Mouse */
- lasips2_init(addr_space, LASI_PS2KBD_HPA,
- qdev_get_gpio_in(lasi_dev, LASI_IRQ_PS2KBD_HPA));
+ lasips2_initfn(addr_space, LASI_PS2KBD_HPA,
+ qdev_get_gpio_in(lasi_dev, LASI_IRQ_PS2KBD_HPA));
/* register power switch emulation */
qemu_register_powerdown_notifier(&hppa_system_powerdown_notifier);
diff --git a/hw/input/lasips2.c b/hw/input/lasips2.c
index 2caa80bd3c..85da4081e3 100644
--- a/hw/input/lasips2.c
+++ b/hw/input/lasips2.c
@@ -245,8 +245,8 @@ static void lasips2_port_set_irq(void *opaque, int level)
lasips2_update_irq(port->parent);
}
-void lasips2_init(MemoryRegion *address_space,
- hwaddr base, qemu_irq irq)
+LASIPS2State *lasips2_initfn(MemoryRegion *address_space,
+ hwaddr base, qemu_irq irq)
{
LASIPS2State *s;
DeviceState *dev;
@@ -272,6 +272,8 @@ void lasips2_init(MemoryRegion *address_space,
memory_region_init_io(&s->mouse.reg, NULL, &lasips2_reg_ops, &s->mouse,
"lasips2-mouse", 0x100);
memory_region_add_subregion(address_space, base + 0x100, &s->mouse.reg);
+
+ return s;
}
static const TypeInfo lasips2_info = {
diff --git a/include/hw/input/lasips2.h b/include/hw/input/lasips2.h
index ddcea74c14..5a35c22f73 100644
--- a/include/hw/input/lasips2.h
+++ b/include/hw/input/lasips2.h
@@ -33,6 +33,7 @@ struct LASIPS2State {
#define TYPE_LASIPS2 "lasips2"
OBJECT_DECLARE_SIMPLE_TYPE(LASIPS2State, LASIPS2)
-void lasips2_init(MemoryRegion *address_space, hwaddr base, qemu_irq irq);
+LASIPS2State *lasips2_initfn(MemoryRegion *address_space, hwaddr base,
+ qemu_irq irq);
#endif /* HW_INPUT_LASIPS2_H */
--
2.30.2
- [PATCH v2 32/54] ps2: use ps2_raise_irq() instead of calling update_irq() directly, (continued)
- [PATCH v2 32/54] ps2: use ps2_raise_irq() instead of calling update_irq() directly, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 33/54] ps2: introduce ps2_lower_irq() instead of calling update_irq() directly, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 34/54] ps2: add gpio for output IRQ and optionally use it in ps2_raise_irq() and ps2_lower_irq(), Mark Cave-Ayland, 2022/06/24
- [PATCH v2 35/54] pckbd: replace irq_kbd and irq_mouse with qemu_irq array in KBDState, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 38/54] lasips2: QOMify LASIPS2State, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 37/54] pl050: add QEMU interface comment, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 36/54] pl050: switch over from update_irq() function to PS2 device gpio, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 39/54] lasips2: move lasips2 QOM types from lasips2.c to lasips2.h, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 40/54] lasips2: rename lasips2_init() to lasips2_initfn() and update it to return the LASIPS2 device,
Mark Cave-Ayland <=
- [PATCH v2 41/54] lasips2: implement lasips2_init() function, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 43/54] lasips2: move initialisation of PS2 ports from lasi_initfn() to lasi_init(), Mark Cave-Ayland, 2022/06/24
- [PATCH v2 45/54] lasips2: implement lasips2_realize(), Mark Cave-Ayland, 2022/06/24
- [PATCH v2 42/54] lasips2: move mapping of LASIPS2 registers to HPPA machine, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 46/54] lasips2: use sysbus IRQ for output IRQ, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 47/54] lasips2: switch over from update_irq() function to PS2 device gpio, Mark Cave-Ayland, 2022/06/24
- [PATCH v2 48/54] lasips2: add QEMU interface comment, Mark Cave-Ayland, 2022/06/24