[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Protux-support] no sound, no buses

From: webmapper
Subject: [Protux-support] no sound, no buses
Date: Tue, 10 Feb 2004 00:37:18 +0100
User-agent: Internet Messaging Program (IMP) 3.2.2

Hi the list !

I am new to sound on linux and to Protux. I want to use Protux to record
and reshape sounds to be played by Beast.
It was a bit hard to install Beast, but now, it's running fine and it is
real fun.
I had some headaches installing Protux and finally managed to have the
0.20.1 version running. The interface is really cool, but . . . I don't
have any sound coming out (or in) : on the left side of the interface, I
have an "Invalid bus" message next to the green and the red square ligth
for every track.
I tried the <BV> and <BN> commands but the lists are empty.
When I run "protux --detectbuses" (or whatever is the command option to
display the buses), it returns : "no buses" (or something like that).

It seems that I should have a /proc/asound/cards "directory", but when I
do :
cat /proc/asound/cards
it returns : no directory, or no file.
How comes that my computer plays sounds and that I don't have anything
/proc/asound/cards ? ? ?

As I am really far from a linux-sound guru, I don't really understand
what is going on.
Any help will be very appreciated...
Following are the content of /etc/modules.conf and the output of "cat
The computer is a laptop with Fedora Core 1. I am not sure but I suppose
the sound card is integrated in the motherboard.

Do  I have troubles with the alsa module, or with the Mustux library, or
with Protux, or something else ? ? ?


----------- content of /etc/modules.conf -------------
alias eth0 tulip
alias usb-controller usb-uhci
alias sound-slot-0 via82cxxx_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :

----------- output of "cat /proc/modules" -------------
address@hidden root]# cat /proc/modules
nls_iso8859-1           3548   0 (autoclean)
nls_cp437               5180   0 (autoclean)
vfat                   12812   0 (autoclean)
fat                    38488   0 (autoclean) [vfat]
via82cxxx_audio        24056   1 (autoclean)
ac97_codec             17064   0 (autoclean) [via82cxxx_audio]
uart401                 8356   0 (autoclean) [via82cxxx_audio]
sound                  73300   0 (autoclean) [via82cxxx_audio uart401]
soundcore               6500   4 (autoclean) [via82cxxx_audio sound]
ide-cd                 35488   0 (autoclean)
cdrom                  33216   0 (autoclean) [ide-cd]
parport_pc             18788   1 (autoclean)
lp                      8868   0 (autoclean)
parport                36800   1 (autoclean) [parport_pc lp]
autofs                 13236   0 (autoclean) (unused)
ds                      8616   2
yenta_socket           13728   2
pcmcia_core            56288   0 [ds yenta_socket]
tulip                  43200   0
ipt_REJECT              4344   1 (autoclean)
ipt_state               1080   2 (autoclean)
ip_conntrack           28840   1 (autoclean) [ipt_state]
iptable_filter          2444   1 (autoclean)
ip_tables              15264   3 [ipt_REJECT ipt_state iptable_filter]
floppy                 57020   0 (autoclean)
sg                     35852   0 (autoclean) (unused)
scsi_mod              107080   1 (autoclean) [sg]
keybdev                 2944   0 (unused)
hid                    24356   0 (unused)
usb-uhci               25964   0 (unused)
usbcore                78368   1 [hid usb-uhci]
mousedev                5428   1 (autoclean)
input                   5824   0 (autoclean) [keybdev hid mousedev]
ext3                   70532   1
jbd                    51732   1 [ext3]

reply via email to

[Prev in Thread] Current Thread [Next in Thread]