[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

General Problems w/ Monit - Some Assistance Requested.

From: Matthew Marlowe
Subject: General Problems w/ Monit - Some Assistance Requested.
Date: Thu, 4 Nov 2004 08:14:26 -0500

I configured and installed monit successfully.  I am also running it
from inittab with the following parameters:

mo:2345:respawn:/usr/local/bin/monit -l syslog -d 60 -Ic /etc/monitrc

This is my /etc/monitrc file:

check process asterisk with pidfile /var/run/
   group root
   start program = "/etc/rc.d/init.d/asterisk restart"
   stop  program = "/etc/rc.d/init.d/asterisk stop"
   if 5 restarts within 5 cycles then timeout
   alert address@hidden
   alert address@hidden on { timeout }

set httpd port 4610

It's very odd what the program does, for starters... It is running
although monit status says can not connect to daemon.  In addition
it's not binding to the http port, and I've tried different ports and
I've tried binding it only to one ip as well.

In addition it had some odd problem restarting asterisk but I think
when I added group root that fixed the problem.  the trace.out was
extremely long and large and I was tired.

Any help would be appreciated, I'd like to find out why the daemon is
not running correctly.  Even though I cant connect via http or use
command line options, it will restart asterisk if I kill it manually
and wait 60 seconds.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]