[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users] how to use linphone in a private network behind fir

From: Alastair Johnson
Subject: Re: [Linphone-users] how to use linphone in a private network behind firewall/gateway
Date: Wed, 25 Feb 2009 17:22:00 +0000
User-agent: Thunderbird (X11/20090105)

Sounds like a firewall problem, but you haven't given much detail of your situation. Getting SIP through firewalls can be tricky and there are many things that can go wrong. There are multiple ports used by SIP for setting up the call, and RTP for passing the audio /video data, and they are variable. A comprehensive answer would be huge, so here are some pointers for further reading.

The most common solution is to use STUN, but in some situations (like mine) it's unreliable. I can't give you any pointers on that as it doesn't work for me.

If you have control of your firewall I suggest using an outbound proxy such as siproxd since this makes life much simpler, especially as you have multiple clients behind the firewall. Siproxd has config examples for running it both on and behind the firewall, depending on what suits your situation. This includes which ports will need forwarding and where to. I haven't had a problem since I installed this. Outbound proxies are increasingly appearing on ADSL routers, so if that's what you're using t might be worth checking the manual.

If you don't have control of the firewall then you'll have to speak nicely to firewall admin ;-) Good luck!

Harishkumar V wrote:
Dear All,

I have installed linphone-3.0.0 release with plugins in 2 linux x-86 machine's running fedora core 8 release.

i created 2 sip accounts in <>.

firstly, in lan , i tested linphone using this setup,

user a -> sip:address@hidden <mailto:address@hidden>
user b -> sip:address@hidden <mailto:address@hidden>

it worked, voice is working. video not tried.

now i tried to test in my real network,

i am in a private network behind a firewall/gateway which is connected to internet.

in this test, the sip registration itself failed.

in linphone debug, no response from <> timed out came.

in my terminal, if i try to ping <>, it will resolve but will not ping as the firewall/gateway is in place.

guys help me in sorting out this.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]