[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: subplot errors in 5.2.0

From: Doug Stewart
Subject: Re: subplot errors in 5.2.0
Date: Fri, 21 Feb 2020 19:54:37 -0500

On Fri, Feb 21, 2020 at 6:46 PM Kwan Lowe <address@hidden> wrote:
On Fri, Feb 21, 2020 at 2:05 PM Mike Miller <address@hidden> wrote:

> Welcome!

Thanks, Mike!

> I can't reproduce these errors. If you look at subplot.m, these first
> warnings indicate that the "position" property of your figure contains
> zeros for height and width.

Thank you for looking into this. I am not explicitly setting any
position parameters in my plots. Most of them are code examples that
have been running for at least a year without issue.

I did test another couple platforms. It works properly on Windows and
MacOS but fails on every Linux I've tried. This is the process I'm

1. Launch Octave in GUI mode
2. Go to Command Window
3. Type the following:
   > x=linspace(-3,3)
   > subplot(2,1,1)  % This command fails immediately on Linux
   > plot(x, sin(x))

Under all the Linux versions that I've tried (Ubuntu, Mint 19.02,
CentOS) and with both the Flatpak, Snap and normal installations by
the default package repos (Apt, RPM, etc), they all fail.

I started digging through the libraries.  The subplot.m files are the
same between the 5.2.0 and 5.1.0 so I'm thinking it's something
outside of this specific library.

This works for me on ubuntu

DASCertificate for 206392

reply via email to

[Prev in Thread] Current Thread [Next in Thread]