[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling octave fails on building flex

From: address@hidden
Subject: Re: compiling octave fails on building flex
Date: Mon, 18 Dec 2017 09:45:17 -0700

Any suggestions? The other machine doesn't fail on these (gdb and nsis, I haven't built package binaries on the other one, and only accidentally let it slip on this one), so I must have setup dependencies inconsistently? I'll move the successful octave-4.3.0+.tar.gz to the other machine which successfully does make nsis-installer and see if I can combine them. But I'd still like to solve this so I can reliably build all the way through on both machines individually.

Do you have the latest mxe-octave? JWE pushed a patch for of-general a few days ago that may have fixed the issues for that package.

For gdb, there was probally a previous error in the build that prevented bfd/libbfd.a etc from being built that may be actual cause of the error


I thought I did have that patch applied. When I tried to look to see what the failing lines were, I thought they came from the patch, but I wasn't sure. My next builds will update the repo first to make sure. 

The failure with gdb and nsis was most likely what you said, because after make clean, they eventually built fine with make nsis-installer and ./configure --enable-devel-tools --enable-binary-packages --enable-octave=default --enable-qt5 --enable-64 --enable-windows-64.  Oddly this time it got caught on of-image and of-gsl as well as of-general. Image and gsl claimed to fail on the same error that they couldn't find "octave". In any case I skipped building each by commenting out the build lines in the three associated build files. All other of- packages built fine, and the installer worked, but it didn't have the bug fixes that i just verified on the same machine in the linux vm build. Maybe I wasn't careful enough to make sure it built with the newly built linux version when it made the Windows installer? If my record keeping is accurate, it shows I built with make and not make  hg-octave-dist like I thought, so likely the octave tar wasn't moved to the pkg directory automatically. The successful prior build of the linux build might have still been hanging around when I tested it after the successful make command making me assume it was going to be used in the nsis- installer build. I'll try to repeat the successful build process on the other machine today and double check I use the right octave tar for it.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]