[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Stress mark in a graph

From: Dmitri A. Sergatskov
Subject: Re: Stress mark in a graph
Date: Tue, 12 May 2015 13:05:05 -0500


Please Cc replies to octave list.

On Tue, May 12, 2015 at 12:45 PM, Leticia Peña <address@hidden> wrote:
I get this error:

error: print.m: PNGCAIRO output is not available for GL2PS output

​GL2PS is used by fltk graphics backend.
You should be using gnuplot.


error: called from:
error:   /usr/share/octave/3.8.1/m/plot/util/private/__fltk_print__.m at line 144, column 7
error:   /usr/share/octave/3.8.1/m/plot/util/print.m at line 425, column 14
error:   /home/lpena/Escritorio/pfc/OCTAVE/compensarEscalado.m at line 173, column 21

Do you know what I must install to be able to run this?

Thanks and regards,

2015-05-11 2:29 GMT+02:00 Dmitri A. Sergatskov <address@hidden>:
On Sun, May 10, 2015 at 10:45 AM, Freddy Omar López Quintero <address@hidden> wrote:

Your answer works in the figure that appears after I run the script, but not in the .png that is saved automatically in my computer by print(nombre_grafica, "-color", "-dpng"). Instead of 'ó', a strange symbol appears in the title. I have tried to save it manually, but it isn't still working. Even not if I save it in other format (I've tried with .jpg and .gif).

I'm using LinuxMint and Octave 3.8.

​Thanks for your answer.

I've tried changing the plotting program and I had the same problem as you:

set(gca, "title", text("string", "Señora de España"))
print -dpng test.png

​Change print command to
print -dpngcairo test.png

(I assume your gnuplot has pngcairo terminal.)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]