On 31-Jan-2006, David Bateman wrote:
| >
| > Thanks,
| >
| > jwe
| >
| I wouldn't just do a straight swap. I'd rather do
|
| nonzero -> nnz
| nnz -> sz_nnz
|
| or something similar..
Yes, that's what I was suggesting:
| > think that will just lead to more mistakes like I just made. Also,
| > perhaps we could rename the nonzero function at the same time, to
make
| > it clear what that really means, and how it is different from nnz
| > (which, as I understand it, is supposed to mean the number of nonzero
| > elements stored in the matrix). What does nonzero count? nnz +/-
what?
| nonzero doesn't really describe the fact that it
| is really the amount of memory allocated to the hold sparse values...
OK, then how about capacity, since we already have that? From Sparse.h:
// Note that capacity and nnz are the amount of storage for non-zero
// elements, while nonzero is the actual number of non-zero terms
octave_idx_type capacity (void) const { return rep->length (); }
octave_idx_type nnz (void) const { return capacity (); }
jwe