[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Windows network installation

From: Mark Veraar
Subject: Re: Windows network installation
Date: Wed, 24 Jul 2002 11:09:40 -0500

----- Original Message -----
From: "Andy Adler" <address@hidden>
To: "Mark Veraar" <address@hidden>
Cc: "help-octave" <address@hidden>
Sent: Sunday, July 07, 2002 3:14 AM
Subject: Re: Windows network installation

> On Fri, 5 Jul 2002, Mark Veraar wrote:
> > I installed octave-windows-2000oct25d.exe in Windows 2000. That's the
> > recent version of Windows Octave I think?
> Octave windows builds are based on cygwin, which mounts the
> root directory "/" to somewhere in the windows folder heirarchy.
> For octave-windows-2000oct25d.exe, I believe / maps to
> C:\program files\gnu\octave.
> You can't cd .. below /.
> However, cygwin understands normal windows paths, so you can
> say.
> cd "C:/path/to/somewhere"
> or even
> cd "D:\\path\\to\\somewhere\\else"
> andy
> _______________________________________
> Andy Adler,                address@hidden
I used octave-windows-2000oct25d.exe.
the cd commands don't work out of the "root" (as you defined it). I found a
solution to the problem: change the root.

I changed my octave.bat file like this:
@echo off
:: ..generated by GNU Octave setup.bat
if not exist \tmp\nul mkdir \tmp
"e:\gnu\octave\bin\bash" --login start
rd \tmp

So my octave is installed in e:\gnu\octave and I want c:\ to be the working
directory. This works OK. Now I can go to alle the sub-directories of c:\
It's still not possible to change to d: or something else.

I have another question about Octave on Windows XP. I saw you alse installed
Octave on XP. Octave doesn't work at my Windows XP.
When I try to load Octave, the following (translated from dutch to
english )error occured:
the system is unable to find the given path

This is because of the command
"\bin\bash" --login start
in the octave.bat file. Windows XP doesn't understand
but does understand

When I change this the following error occured
start: start: No such file or directory


So I tried to just do the command:"
bash --login start
in a dos window after creating a tmp directory.
The following error occured:
start: rxvt: command not found


So finally I tried the (long) command in the start file from the bin
rxvt -fn "Courier New-14" -tn linux -title "GNU Octave 2.1.31" -n "GNU
Octave" +sr -sl 1000 -e octave

Then something happens! I think the octave window opens and then closes in
less than 1/10 second.

What happened?

Mark Veraar

Octave is freely available under the terms of the GNU GPL.

Octave's home on the web:
How to fund new projects:
Subscription information:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]