[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: plot does not work [gnuplot is ok].

From: maechler
Subject: Re: plot does not work [gnuplot is ok].
Date: Wed, 9 Mar 1994 18:16:38 +0100

I wrote a few hours ago:
> > I have installed octave "alright",
> > i.e., I tried a few things and they worked ...,
> > 
> > but plotting does NOT.
> > I have installed and tested out  gnuplot alright.
> > 
> > Here is a sample session:
> > 
> > ingrid{local}358% octave
> > Octave, version 1.0.  Copyright (C) 1992, 1993, 1994 John W. Eaton.
> > This is free software with ABSOLUTELY NO WARRANTY.
> > For details, type `warranty'.
> > 
> > octave:1> show
> > warning: plot: unable to open pipe to `gnuplot'
> > octave:2> quit
> > 

And Dave Rebnord rightly asks
> What sort of system are you running octave on?
> There was a problem opening a pipe to gnuplot on NeXT systems, because of 
> bugs  
> in libg++-2.5.3 on NeXT systems.
> If you are running on a NeXT let me know. I have a binary for NeXT systems for
> which plotting works or you can get the binary from, but 
> the  
> binaries are the same since I provided the one at Texas.
> If you are not running on a NeXT it may be that your system has a similar bug 
> in libg++-2.5.3 in which case I can send you the patches I applied.

System: Sun SPARC [1,2,10,..]
OS:     SunOS 4.1.2 and 4.1.3,

octave compiled with newest GCC and libg++

This is such a standard system that I cannot imagine that I am the only
using it + octave + gnuplot.

Or am I ?

Does it make sense to try Dave's patch(es) ?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]