[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Disabling ctrl-alt-<arrow> keys

From: Drew Adams
Subject: Re: [h-e-w] Disabling ctrl-alt-<arrow> keys
Date: Mon, 27 Jul 2015 21:40:51 -0700 (PDT)

> > I have my arrow keys C-M-down, C-M-up, C-M-right, and C-M-left mapped in
> > Emacs to some of my functions (that used to work) and after I got a new
> > Windows 7 laptop (same OS and Emacs 24.3.1, as before), I can't use
> > those keys as some program is intercepting/disabling them. My graphics card
> > hot keys are disabled but Emacs still doesn't respond. Any suggestions?
> Did you try using w32-register-hot-key for them?


I use Windows 7 (64-bit), I have no problem binding and using `C-M-up'
etc., and I do not need to use `w32-register-hot-key' for them.  The
same was true for Windows XP.

On the other hand, with Windows XP I needed to use `w32-register-hot-key'
to give Emacs access to `M-TAB' and `M-S-TAB', and that worked, but it
does not work for Windows 7.  For Windows 7 I have not found a solution
for those keys.  (But again, I have no problem for `C-M-up' etc.)

(And all of this is true in my case for Emacs 20 through Emacs 25 - the
Emacs release makes no difference.)

Sarir: You do not say how you try to bind `C-M-up' etc.  For me it works
to use any of the usual forms - for example:

(global-set-key [(control meta up)] 'shrink-frame)
(global-set-key (kbd "C-M-<up>")    'shrink-frame)
(global-set-key [C-M-up]            'shrink-frame)

"some program is intercepting/disabling them" - That would be my guess
too.  You say you disabled any graphics-card and other hotkeys, but
that would still be my guess.  What happens when you use `C-M-up' etc.
outside of Emacs?

I guess you have already tried googling about this?  I see that some
video cards use Alt + Cntl + left-arrow (up-arrow etc.) to rotate the

reply via email to

[Prev in Thread] Current Thread [Next in Thread]