bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: push parser


From: Bob Rossi
Subject: Re: push parser
Date: Wed, 13 Dec 2006 07:14:05 -0500
User-agent: Mutt/1.5.12-2006-07-14

On Tue, Dec 12, 2006 at 05:11:39PM -0500, Joel E. Denny wrote:
> On Sun, 10 Dec 2006, Bob Rossi wrote:
> 
> > On Mon, Dec 04, 2006 at 06:15:46PM -0500, Joel E. Denny wrote:
> > > 6. I read somewhere in this thread that yypushparse will never modify its 
> > > yynchar, yynlval, and yynlloc arguments.  Shouldn't they be const then?
> > 
> > Sure. Here's a patch, what do you think?
> 
> I would appreciate Paul Eggert's opinion on arguments with multiple 
> const's like this one:
> 
>   const YYSTYPE * const yynlval
> 
> I'm pretty sure he'll at least want to see the first const moved:
> 
>   YYSTYPE const * const ynlval
> 
> He may want to see the second const removed.
> 
> Sorry, I'm not sure why I listed yynchar.  I was actually just thinking of 
> pointer arguments.
> 
> > Please give me direction on
> > what else you would like me to modify in push.c. I'm not sure how many
> > items on the original list you posted you still consider valid.
> 
> How about replacing yypstate_init with yypstate_new and yypstate_delete?  
> Sorry, I forgot about this during the previous renaming, but this will 
> probably be a nice self-contained patch anyway.  Also, did you look into 
> using b4_c_function_def for these definitions?  If you agree with these 
> ideas, you could proceed with them while we wait for Paul's response to 
> the above.

OK, do you want me to simply rename yypstateinit to yypstate_new and
then add yypstate_delete to just do a free of the data allocated?

Bob Rossi




reply via email to

[Prev in Thread] Current Thread [Next in Thread]