bison-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: push parser


From: Bob Rossi
Subject: Re: push parser
Date: Wed, 13 Dec 2006 18:16:16 -0500
User-agent: Mutt/1.5.12-2006-07-14

On Wed, Dec 13, 2006 at 02:53:33PM -0500, Joel E. Denny wrote:
> On Wed, 13 Dec 2006, Bob Rossi wrote:
> 
> > On Tue, Dec 12, 2006 at 05:11:39PM -0500, Joel E. Denny wrote:
> 
> > > How about replacing yypstate_init with yypstate_new and yypstate_delete?  
> > > Sorry, I forgot about this during the previous renaming, but this will 
> > > probably be a nice self-contained patch anyway.  Also, did you look into 
> > > using b4_c_function_def for these definitions?  If you agree with these 
> > > ideas, you could proceed with them while we wait for Paul's response to 
> > > the above.
> > 
> > OK, do you want me to simply rename yypstateinit to yypstate_new and
> > then add yypstate_delete to just do a free of the data allocated?
> 
> Yes, if that's agreeable to you.  (And don't forget b4_c_function_def.)
> 
> Also, Paul has responded about your previous patch, so you could revise 
> that.

How does this look?

Thanks,
Bob Rossi

2006-12-13  Bob Rossi  <address@hidden>

        * data/push.c (yypstate_init #define): Deleted.
        (yypsate_new, yypstate_delete #define): Added.
        (yypstate_init function_decl): Deleted.
        (yypsate_new, yypstate_delete function_decl): Added.
        (yypush_parse): Changed parameters yynval and yynlloc to be const.
        * tests/calc.at (_AT_DATA_CALC_Y): Use new yypstate_new
        yypstate_delete functions.

Attachment: push.c.diff
Description: Text document


reply via email to

[Prev in Thread] Current Thread [Next in Thread]