[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Wget-dev] wget2 | failed to build wget2 when runing ./bootstrap (#4

From: thaij
Subject: Re: [Wget-dev] wget2 | failed to build wget2 when runing ./bootstrap (#407)
Date: Sun, 14 Oct 2018 01:56:49 +0000

@rockdaboot  the fallback to the non-python gnulib-tool doesn't work, i don't 
know whether it is relevant with what i have done with git branch operation 
locally, when i ran ./bootsrap failed with python info, i checked it source 
code and my python version, created a new branch, changed the line with 
'sys.version_info.major' to 'sys.version_info[0] == 2' in the 
gnulib/pygnulib/constants.py source file to solve it,  then the result is the 
same as before, so i changed it (pygnulib/constants.py) back as it is, evently, 
i posted the issue when i found i can't solve it by myself. That's all.

     As to the Work-around that you suggest, I tried it, and it worked, solve 
the relevant python issue . But it failed with another problem. the partial 
info like this:
running: AUTOPOINT=true LIBTOOLIZE=true autoreconf --verbose --install --force 
-I m4  --no-recursive
autoreconf: Entering directory `.'
autoreconf: running: true --force
autoreconf: running: aclocal --force -I m4 ${ACLOCAL_FLAGS}
configure.ac:508: warning: macro `AM_PATH_GPGME' not found in library
configure.ac:6: error: Autoconf version 2.67 or higher is required
configure.ac:6: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
aclocal: autom4te failed with exit status: 63
autoreconf: aclocal failed with exit status: 63
./bootstrap: autoreconf failed

    and i went back to the README.md's build requirement, found it doesn't have 
the autoconf version limit. so I fell info the state of solving the package 
dependicy issue. i'll think about it later again, Thanks for all.

Reply to this email directly or view it on GitLab: 
You're receiving this email because of your account on gitlab.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]