[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 23/25] tests/vm/basevm.py: use cmd() instead of qmp()
From: |
John Snow |
Subject: |
[PULL 23/25] tests/vm/basevm.py: use cmd() instead of qmp() |
Date: |
Fri, 13 Oct 2023 15:09:38 -0400 |
From: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>
We don't expect failure here and need 'result' object. cmd() is better
in this case.
Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>
Reviewed-by: Eric Blake <eblake@redhat.com>
Message-id: 20231006154125.1068348-14-vsementsov@yandex-team.ru
Signed-off-by: John Snow <jsnow@redhat.com>
---
tests/vm/basevm.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/vm/basevm.py b/tests/vm/basevm.py
index a97e23b0ce..8aef4cff96 100644
--- a/tests/vm/basevm.py
+++ b/tests/vm/basevm.py
@@ -312,8 +312,8 @@ def boot(self, img, extra_args=[]):
self._guest = guest
# Init console so we can start consuming the chars.
self.console_init()
- usernet_info = guest.qmp("human-monitor-command",
- command_line="info usernet").get("return")
+ usernet_info = guest.cmd("human-monitor-command",
+ command_line="info usernet")
self.ssh_port = get_info_usernet_hostfwd_port(usernet_info)
if not self.ssh_port:
raise Exception("Cannot find ssh port from 'info usernet':\n%s" % \
--
2.41.0
- [PULL 18/25] iotests: add some missed checks of qmp result, (continued)
- [PULL 18/25] iotests: add some missed checks of qmp result, John Snow, 2023/10/13
- [PULL 16/25] python/machine.py: upgrade vm.cmd() method, John Snow, 2023/10/13
- [PULL 17/25] iotests: QemuStorageDaemon: add cmd() method like in QEMUMachine., John Snow, 2023/10/13
- [PULL 06/25] python/machine: remove unused sock_dir argument, John Snow, 2023/10/13
- [PULL 05/25] python/machine: use socketpair() for qtest connection, John Snow, 2023/10/13
- [PULL 14/25] python: rename QEMUMonitorProtocol.cmd() to cmd_raw(), John Snow, 2023/10/13
- [PULL 22/25] iotests.py: pause_job(): drop return value, John Snow, 2023/10/13
- [PULL 19/25] iotests: refactor some common qmp result checks into generic pattern, John Snow, 2023/10/13
- [PULL 20/25] iotests: drop some extra semicolons, John Snow, 2023/10/13
- [PULL 15/25] python/qemu: rename command() to cmd(), John Snow, 2023/10/13
- [PULL 23/25] tests/vm/basevm.py: use cmd() instead of qmp(),
John Snow <=
- [PULL 24/25] scripts: add python_qmp_updater.py, John Snow, 2023/10/13
- [PULL 21/25] iotests: drop some extra ** in qmp() call, John Snow, 2023/10/13
- [PULL 25/25] python: use vm.cmd() instead of vm.qmp() where appropriate, John Snow, 2023/10/13
- Re: [PULL 00/25] Python patches, Stefan Hajnoczi, 2023/10/16