[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 14/25] python: rename QEMUMonitorProtocol.cmd() to cmd_raw()
From: |
John Snow |
Subject: |
[PULL 14/25] python: rename QEMUMonitorProtocol.cmd() to cmd_raw() |
Date: |
Fri, 13 Oct 2023 15:09:29 -0400 |
From: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>
Having cmd() and command() methods in one class doesn't look good.
Rename cmd() to cmd_raw(), to show its meaning better.
We also want to rename command() to cmd() in future, so this commit is
a necessary step.
Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>
Reviewed-by: Eric Blake <eblake@redhat.com>
Message-id: 20231006154125.1068348-5-vsementsov@yandex-team.ru
Signed-off-by: John Snow <jsnow@redhat.com>
---
python/qemu/machine/machine.py | 2 +-
python/qemu/qmp/legacy.py | 4 ++--
tests/qemu-iotests/iotests.py | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/python/qemu/machine/machine.py b/python/qemu/machine/machine.py
index d539e91268..50bba33729 100644
--- a/python/qemu/machine/machine.py
+++ b/python/qemu/machine/machine.py
@@ -702,7 +702,7 @@ def qmp(self, cmd: str,
conv_keys = True
qmp_args = self._qmp_args(conv_keys, args)
- ret = self._qmp.cmd(cmd, args=qmp_args)
+ ret = self._qmp.cmd_raw(cmd, args=qmp_args)
if cmd == 'quit' and 'error' not in ret and 'return' in ret:
self._quit_issued = True
return ret
diff --git a/python/qemu/qmp/legacy.py b/python/qemu/qmp/legacy.py
index fe115e301c..e5fa1ce9c4 100644
--- a/python/qemu/qmp/legacy.py
+++ b/python/qemu/qmp/legacy.py
@@ -194,8 +194,8 @@ def cmd_obj(self, qmp_cmd: QMPMessage) -> QMPMessage:
)
)
- def cmd(self, name: str,
- args: Optional[Dict[str, object]] = None) -> QMPMessage:
+ def cmd_raw(self, name: str,
+ args: Optional[Dict[str, object]] = None) -> QMPMessage:
"""
Build a QMP command and send it to the QMP Monitor.
diff --git a/tests/qemu-iotests/iotests.py b/tests/qemu-iotests/iotests.py
index 145c682713..0c061d8986 100644
--- a/tests/qemu-iotests/iotests.py
+++ b/tests/qemu-iotests/iotests.py
@@ -460,7 +460,7 @@ def __init__(self, *args: str, instance_id: str = 'a', qmp:
bool = False):
def qmp(self, cmd: str, args: Optional[Dict[str, object]] = None) \
-> QMPMessage:
assert self._qmp is not None
- return self._qmp.cmd(cmd, args)
+ return self._qmp.cmd_raw(cmd, args)
def get_qmp(self) -> QEMUMonitorProtocol:
assert self._qmp is not None
--
2.41.0
- [PULL 09/25] configure: fix error message to say Python 3.8, (continued)
- [PULL 09/25] configure: fix error message to say Python 3.8, John Snow, 2023/10/13
- [PULL 12/25] qmp_shell.py: _fill_completion() use .command() instead of .cmd(), John Snow, 2023/10/13
- [PULL 13/25] scripts/cpu-x86-uarch-abi.py: use .command() instead of .cmd(), John Snow, 2023/10/13
- [PULL 10/25] Python: Enable python3.12 support, John Snow, 2023/10/13
- [PULL 07/25] Python/iotests: Add type hint for nbd module, John Snow, 2023/10/13
- [PULL 18/25] iotests: add some missed checks of qmp result, John Snow, 2023/10/13
- [PULL 16/25] python/machine.py: upgrade vm.cmd() method, John Snow, 2023/10/13
- [PULL 17/25] iotests: QemuStorageDaemon: add cmd() method like in QEMUMachine., John Snow, 2023/10/13
- [PULL 06/25] python/machine: remove unused sock_dir argument, John Snow, 2023/10/13
- [PULL 05/25] python/machine: use socketpair() for qtest connection, John Snow, 2023/10/13
- [PULL 14/25] python: rename QEMUMonitorProtocol.cmd() to cmd_raw(),
John Snow <=
- [PULL 22/25] iotests.py: pause_job(): drop return value, John Snow, 2023/10/13
- [PULL 19/25] iotests: refactor some common qmp result checks into generic pattern, John Snow, 2023/10/13
- [PULL 20/25] iotests: drop some extra semicolons, John Snow, 2023/10/13
- [PULL 15/25] python/qemu: rename command() to cmd(), John Snow, 2023/10/13
- [PULL 23/25] tests/vm/basevm.py: use cmd() instead of qmp(), John Snow, 2023/10/13
- [PULL 24/25] scripts: add python_qmp_updater.py, John Snow, 2023/10/13
- [PULL 21/25] iotests: drop some extra ** in qmp() call, John Snow, 2023/10/13
- [PULL 25/25] python: use vm.cmd() instead of vm.qmp() where appropriate, John Snow, 2023/10/13
- Re: [PULL 00/25] Python patches, Stefan Hajnoczi, 2023/10/16