[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-ppc] [PATCH v3 10/13] nvdimm: convert nvdimm_mr into a pointer
From: |
David Gibson |
Subject: |
Re: [Qemu-ppc] [PATCH v3 10/13] nvdimm: convert nvdimm_mr into a pointer |
Date: |
Mon, 18 Jun 2018 10:49:50 +1000 |
User-agent: |
Mutt/1.10.0 (2018-05-17) |
On Fri, Jun 15, 2018 at 04:04:45PM +0200, David Hildenbrand wrote:
> This way we can easily check if the region has already been inititalized
> without having to rely on the size of an uninitialized region being 0.
>
> Signed-off-by: David Hildenbrand <address@hidden>
I'm not terribly convinced that this is a worthwhile change, but in
the sense that the patch appears to be technically correct:
Reviewed-by: David Gibson <address@hidden>
> ---
> hw/mem/nvdimm.c | 9 +++++----
> include/hw/mem/nvdimm.h | 2 +-
> 2 files changed, 6 insertions(+), 5 deletions(-)
>
> diff --git a/hw/mem/nvdimm.c b/hw/mem/nvdimm.c
> index 7260c9c6b1..db7d8c3050 100644
> --- a/hw/mem/nvdimm.c
> +++ b/hw/mem/nvdimm.c
> @@ -43,7 +43,7 @@ static void nvdimm_set_label_size(Object *obj, Visitor *v,
> const char *name,
> Error *local_err = NULL;
> uint64_t value;
>
> - if (memory_region_size(&nvdimm->nvdimm_mr)) {
> + if (nvdimm->nvdimm_mr) {
> error_setg(&local_err, "cannot change property value");
> goto out;
> }
> @@ -75,7 +75,7 @@ static MemoryRegion *nvdimm_get_memory_region(PCDIMMDevice
> *dimm, Error **errp)
> {
> NVDIMMDevice *nvdimm = NVDIMM(dimm);
>
> - return &nvdimm->nvdimm_mr;
> + return nvdimm->nvdimm_mr;
> }
>
> static void nvdimm_realize(PCDIMMDevice *dimm, Error **errp)
> @@ -102,9 +102,10 @@ static void nvdimm_realize(PCDIMMDevice *dimm, Error
> **errp)
> return;
> }
>
> - memory_region_init_alias(&nvdimm->nvdimm_mr, OBJECT(dimm),
> + nvdimm->nvdimm_mr = g_new(MemoryRegion, 1);
> + memory_region_init_alias(nvdimm->nvdimm_mr, OBJECT(dimm),
> "nvdimm-memory", mr, 0, pmem_size);
> - nvdimm->nvdimm_mr.align = align;
> + nvdimm->nvdimm_mr->align = align;
> }
>
> /*
> diff --git a/include/hw/mem/nvdimm.h b/include/hw/mem/nvdimm.h
> index 9340631cfc..c5c9b3c7f8 100644
> --- a/include/hw/mem/nvdimm.h
> +++ b/include/hw/mem/nvdimm.h
> @@ -74,7 +74,7 @@ struct NVDIMMDevice {
> * it's the PMEM region in NVDIMM device, which is presented to
> * guest via ACPI NFIT and _FIT method if NVDIMM hotplug is supported.
> */
> - MemoryRegion nvdimm_mr;
> + MemoryRegion *nvdimm_mr;
>
> /*
> * The 'on' value results in the unarmed flag set in ACPI NFIT,
--
David Gibson | I'll have my music baroque, and my code
david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_
| _way_ _around_!
http://www.ozlabs.org/~dgibson
signature.asc
Description: PGP signature
- Re: [Qemu-ppc] [PATCH v3 03/13] pc-dimm: rename pc_dimm_memory_* to pc_dimm_*, (continued)
- [Qemu-ppc] [PATCH v3 04/13] pc-dimm: remove pc_dimm_get_free_slot() from header, David Hildenbrand, 2018/06/15
- [Qemu-ppc] [PATCH v3 05/13] pc: factor out pc specific dimm checks into pc_memory_pre_plug(), David Hildenbrand, 2018/06/15
- [Qemu-ppc] [PATCH v3 06/13] nvdimm: no need to overwrite get_vmstate_memory_region(), David Hildenbrand, 2018/06/15
- [Qemu-ppc] [PATCH v3 08/13] pc-dimm: merge get_(vmstate_)memory_region(), David Hildenbrand, 2018/06/15
- [Qemu-ppc] [PATCH v3 07/13] hostmem: drop error variable from host_memory_backend_get_memory(), David Hildenbrand, 2018/06/15
- [Qemu-ppc] [PATCH v3 10/13] nvdimm: convert nvdimm_mr into a pointer, David Hildenbrand, 2018/06/15
- [Qemu-ppc] [PATCH v3 11/13] nvdimm: allow setting the label-size to 0, David Hildenbrand, 2018/06/15
- [Qemu-ppc] [PATCH v3 12/13] nvdimm: make get_memory_region() perform checks and initialization, David Hildenbrand, 2018/06/15
- [Qemu-ppc] [PATCH v3 09/13] nvdimm: convert "unarmed" into a static property, David Hildenbrand, 2018/06/15