[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 01/22] target/arm: Rename FPST_FPCR_A32 to FPST_A32
From: |
Peter Maydell |
Subject: |
Re: [PATCH 01/22] target/arm: Rename FPST_FPCR_A32 to FPST_A32 |
Date: |
Tue, 28 Jan 2025 11:02:31 +0000 |
On Mon, 27 Jan 2025 at 23:26, Richard Henderson
<richard.henderson@linaro.org> wrote:
>
> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
> ---
> target/arm/tcg/translate.h | 6 ++--
> target/arm/tcg/translate-vfp.c | 54 +++++++++++++++++-----------------
> 2 files changed, 30 insertions(+), 30 deletions(-)
>
> diff --git a/target/arm/tcg/translate.h b/target/arm/tcg/translate.h
> index 59e780df2e..6ce2471aa6 100644
> --- a/target/arm/tcg/translate.h
> +++ b/target/arm/tcg/translate.h
> @@ -674,7 +674,7 @@ static inline CPUARMTBFlags arm_tbflags_from_tb(const
> TranslationBlock *tb)
> * Enum for argument to fpstatus_ptr().
> */
> typedef enum ARMFPStatusFlavour {
> - FPST_FPCR_A32,
> + FPST_A32,
> FPST_FPCR_A64,
> FPST_FPCR_F16_A32,
> FPST_FPCR_F16_A64,
> @@ -692,7 +692,7 @@ typedef enum ARMFPStatusFlavour {
> * been set up to point to the requested field in the CPU state struct.
> * The options are:
> *
> - * FPST_FPCR_A32
> + * FPST_A32
> * for AArch32 non-FP16 operations controlled by the FPCR
So the reason we had "FPCR" in the names here is, as the
comment notes, because the original distinction was
"operations that use the 'standard FPSCR value'" versus
"operations controlled by the FPCR". But I think with the
profusion of float_status values we've ended up with,
most of which are sort-of-but-not-entirely controlled
by FPCR bits in one way or another, that the "FPCR"
part of the constant name has outlived its usefulness.
So I'm happy with renaming these to be shorter.
thanks
-- PMM
- [PATCH 00/22] target/arm: FEAT_AFP followups for FEAT_SME2, Richard Henderson, 2025/01/27
- [PATCH 01/22] target/arm: Rename FPST_FPCR_A32 to FPST_A32, Richard Henderson, 2025/01/27
- Re: [PATCH 01/22] target/arm: Rename FPST_FPCR_A32 to FPST_A32,
Peter Maydell <=
- [PATCH 03/22] target/arm: Rename FPST_FPCR_F16_A32 to FPST_A32_F16, Richard Henderson, 2025/01/27
- [PATCH 05/22] target/arm: Rename FPST_FPCR_AH* to FPST_AH*, Richard Henderson, 2025/01/27
- [PATCH 02/22] target/arm: Rename FPST_FPCR_A64 to FPST_A64, Richard Henderson, 2025/01/27
- [PATCH 07/22] target/arm: Remove standard_fp_status_f16, Richard Henderson, 2025/01/27
- [PATCH 16/22] target/arm: Simplify DO_VFP_cmp in vfp_helper.c, Richard Henderson, 2025/01/27
- [PATCH 18/22] target/arm: Introduce float*_maybe_ah_chs, Richard Henderson, 2025/01/27
- [PATCH 06/22] target/arm: Introduce CPUARMState.vfp.fp_status[], Richard Henderson, 2025/01/27
- [PATCH 04/22] target/arm: Rename FPST_FPCR_F16_A64 to FPST_A64_F16, Richard Henderson, 2025/01/27
- [PATCH 08/22] target/arm: Remove standard_fp_status, Richard Henderson, 2025/01/27
- [PATCH 09/22] target/arm: Remove ah_fp_status_f16, Richard Henderson, 2025/01/27