[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 2/9] fifo8: introduce head variable for fifo8_peekpop_bufptr(
From: |
Octavian Purdila |
Subject: |
Re: [PATCH 2/9] fifo8: introduce head variable for fifo8_peekpop_bufptr() |
Date: |
Fri, 30 Aug 2024 17:05:00 -0700 |
On Wed, Aug 28, 2024 at 5:23 AM Mark Cave-Ayland
<mark.cave-ayland@ilande.co.uk> wrote:
>
> Rather than operate on fifo->head directly, introduce a new head variable
> which is
> set to the value of fifo->head and use it instead. This is to allow future
> adjustment of the head position within the internal FIFO buffer.
>
> Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
Reviewed-by: Octavian Purdila <tavip@google.com>
> ---
> util/fifo8.c | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/util/fifo8.c b/util/fifo8.c
> index 61bce9d9a0..5faa814a6e 100644
> --- a/util/fifo8.c
> +++ b/util/fifo8.c
> @@ -75,11 +75,12 @@ static const uint8_t *fifo8_peekpop_bufptr(Fifo8 *fifo,
> uint32_t max,
> uint32_t *numptr, bool do_pop)
> {
> uint8_t *ret;
> - uint32_t num;
> + uint32_t num, head;
>
> assert(max > 0 && max <= fifo->num);
> - num = MIN(fifo->capacity - fifo->head, max);
> - ret = &fifo->data[fifo->head];
> + head = fifo->head;
> + num = MIN(fifo->capacity - head, max);
> + ret = &fifo->data[head];
>
> if (do_pop) {
> fifo->head += num;
> --
> 2.39.2
>
- [PATCH 0/9] fifo8: add fifo8_peek(), fifo8_peek_buf() and tests, Mark Cave-Ayland, 2024/08/28
- [PATCH 1/9] fifo8: rename fifo8_peekpop_buf() to fifo8_peekpop_bufptr(), Mark Cave-Ayland, 2024/08/28
- [PATCH 2/9] fifo8: introduce head variable for fifo8_peekpop_bufptr(), Mark Cave-Ayland, 2024/08/28
- [PATCH 3/9] fifo8: add skip parameter to fifo8_peekpop_bufptr(), Mark Cave-Ayland, 2024/08/28
- [PATCH 4/9] fifo8: replace fifo8_pop_bufptr() with fifo8_peekpop_bufptr() in fifo8_pop_buf(), Mark Cave-Ayland, 2024/08/28
- [PATCH 5/9] fifo8: rename fifo8_pop_buf() to fifo8_peekpop_buf(), Mark Cave-Ayland, 2024/08/28
- [PATCH 6/9] fifo8: honour do_pop argument in fifo8_peekpop_buf(), Mark Cave-Ayland, 2024/08/28