[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 5/9] fifo8: rename fifo8_pop_buf() to fifo8_peekpop_buf()
From: |
Alistair Francis |
Subject: |
Re: [PATCH 5/9] fifo8: rename fifo8_pop_buf() to fifo8_peekpop_buf() |
Date: |
Fri, 30 Aug 2024 09:55:17 +1000 |
On Wed, Aug 28, 2024 at 10:25 PM Mark Cave-Ayland
<mark.cave-ayland@ilande.co.uk> wrote:
>
> The fifo8_pop_buf() function will soon also be used for peek operations, so
> rename
> the function accordingly. Create a new fifo8_pop_buf() wrapper function that
> can
> be used by existing callers.
>
> Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
Reviewed-by: Alistair Francis <alistair.francis@wdc.com>
Alistair
> ---
> util/fifo8.c | 8 +++++++-
> 1 file changed, 7 insertions(+), 1 deletion(-)
>
> diff --git a/util/fifo8.c b/util/fifo8.c
> index efe0117b1f..5453cbc1b0 100644
> --- a/util/fifo8.c
> +++ b/util/fifo8.c
> @@ -105,7 +105,8 @@ const uint8_t *fifo8_pop_bufptr(Fifo8 *fifo, uint32_t
> max, uint32_t *numptr)
> return fifo8_peekpop_bufptr(fifo, max, 0, numptr, true);
> }
>
> -uint32_t fifo8_pop_buf(Fifo8 *fifo, uint8_t *dest, uint32_t destlen)
> +static uint32_t fifo8_peekpop_buf(Fifo8 *fifo, uint8_t *dest, uint32_t
> destlen,
> + bool do_pop)
> {
> const uint8_t *buf;
> uint32_t n1, n2 = 0;
> @@ -134,6 +135,11 @@ uint32_t fifo8_pop_buf(Fifo8 *fifo, uint8_t *dest,
> uint32_t destlen)
> return n1 + n2;
> }
>
> +uint32_t fifo8_pop_buf(Fifo8 *fifo, uint8_t *dest, uint32_t destlen)
> +{
> + return fifo8_peekpop_buf(fifo, dest, destlen, true);
> +}
> +
> void fifo8_drop(Fifo8 *fifo, uint32_t len)
> {
> len -= fifo8_pop_buf(fifo, NULL, len);
> --
> 2.39.2
>
>
- [PATCH 2/9] fifo8: introduce head variable for fifo8_peekpop_bufptr(), (continued)
- [PATCH 2/9] fifo8: introduce head variable for fifo8_peekpop_bufptr(), Mark Cave-Ayland, 2024/08/28
- [PATCH 3/9] fifo8: add skip parameter to fifo8_peekpop_bufptr(), Mark Cave-Ayland, 2024/08/28
- [PATCH 4/9] fifo8: replace fifo8_pop_bufptr() with fifo8_peekpop_bufptr() in fifo8_pop_buf(), Mark Cave-Ayland, 2024/08/28
- [PATCH 5/9] fifo8: rename fifo8_pop_buf() to fifo8_peekpop_buf(), Mark Cave-Ayland, 2024/08/28
- [PATCH 6/9] fifo8: honour do_pop argument in fifo8_peekpop_buf(), Mark Cave-Ayland, 2024/08/28
- [PATCH 7/9] fifo8: add fifo8_peek_buf() function, Mark Cave-Ayland, 2024/08/28
- [PATCH 8/9] fifo8: introduce fifo8_peek() function, Mark Cave-Ayland, 2024/08/28