[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 04/13] hw/core/loader-fit: Fix missing ERRP_GUARD() for error_prep
From: |
Philippe Mathieu-Daudé |
Subject: |
[PULL 04/13] hw/core/loader-fit: Fix missing ERRP_GUARD() for error_prepend() |
Date: |
Tue, 12 Mar 2024 09:22:29 +0100 |
From: Zhao Liu <zhao1.liu@intel.com>
As the comment in qapi/error, passing @errp to error_prepend() requires
ERRP_GUARD():
* = Why, when and how to use ERRP_GUARD() =
*
* Without ERRP_GUARD(), use of the @errp parameter is restricted:
...
* - It should not be passed to error_prepend(), error_vprepend() or
* error_append_hint(), because that doesn't work with &error_fatal.
* ERRP_GUARD() lifts these restrictions.
*
* To use ERRP_GUARD(), add it right at the beginning of the function.
* @errp can then be used without worrying about the argument being
* NULL or &error_fatal.
ERRP_GUARD() could avoid the case when @errp is &error_fatal, the user
can't see this additional information, because exit() happens in
error_setg earlier than information is added [1].
In hw/core/loader-fit.c, there are 2 functions passing @errp to
error_prepend() without ERRP_GUARD():
- fit_load_kernel()
- fit_load_fdt()
Their @errp parameters are both the pointers of the local @err virable
in load_fit().
Though they don't cause the issue like [1] said, to follow the
requirement of @errp, add missing ERRP_GUARD() at their beginning.
[1]: Issue description in the commit message of commit ae7c80a7bd73
("error: New macro ERRP_GUARD()").
Cc: Paul Burton <paulburton@kernel.org>
Cc: Aleksandar Rikalo <aleksandar.rikalo@syrmia.com>
Signed-off-by: Zhao Liu <zhao1.liu@intel.com>
Message-ID: <20240311033822.3142585-15-zhao1.liu@linux.intel.com>
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
---
hw/core/loader-fit.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/hw/core/loader-fit.c b/hw/core/loader-fit.c
index b7c7b3ba94..9f20007dbb 100644
--- a/hw/core/loader-fit.c
+++ b/hw/core/loader-fit.c
@@ -120,6 +120,7 @@ static int fit_load_kernel(const struct fit_loader *ldr,
const void *itb,
int cfg, void *opaque, hwaddr *pend,
Error **errp)
{
+ ERRP_GUARD();
const char *name;
const void *data;
const void *load_data;
@@ -178,6 +179,7 @@ static int fit_load_fdt(const struct fit_loader *ldr, const
void *itb,
int cfg, void *opaque, const void *match_data,
hwaddr kernel_end, Error **errp)
{
+ ERRP_GUARD();
Error *err = NULL;
const char *name;
const void *data;
--
2.41.0
- [PULL 00/13] Misc HW patches for 2024-03-12, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 01/13] hw/ide/ahci: Rename ahci_internal.h to ahci-internal.h, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 02/13] hw/pci: add some convenient trace-events for pcie and shpc hotplug, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 03/13] hw/ppc/sam460ex: Support short options for adding drives, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 04/13] hw/core/loader-fit: Fix missing ERRP_GUARD() for error_prepend(),
Philippe Mathieu-Daudé <=
- [PULL 05/13] hw/core/qdev-properties-system: Fix missing ERRP_GUARD() for error_prepend(), Philippe Mathieu-Daudé, 2024/03/12
- [PULL 06/13] hw/misc/ivshmem: Fix missing ERRP_GUARD() for error_prepend(), Philippe Mathieu-Daudé, 2024/03/12
- [PULL 07/13] sun4u: remap ebus BAR0 to use unassigned_io_ops instead of alias to PCI IO space, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 08/13] hw/core: Cleanup unused included headers in cpu-common.c, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 09/13] hw/core: Cleanup unused included header in machine-qmp-cmds.c, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 11/13] hw/gpio: introduce pcf8574 driver, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 10/13] hw/core: Cleanup unused included headers in numa.c, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 12/13] meson.build: Always require an objc compiler on macos hosts, Philippe Mathieu-Daudé, 2024/03/12
- [PULL 13/13] docs/about/deprecated.rst: Move SMP configurations item to system emulator section, Philippe Mathieu-Daudé, 2024/03/12
- Re: [PULL 00/13] Misc HW patches for 2024-03-12, Peter Maydell, 2024/03/12